Page MenuHomePhabricator

System time on sl projects
Closed, ResolvedPublic

Description

There is a need to change the system time on slovene projects from UTC to slovenian local time. Slovene Wikipedia already uses local time, but other projects (s, q, b, wikt, v) still need to be unified with Wikipedia.

Initial request
https://meta.wikimedia.org/wiki/Steward_requests/Miscellaneous/2016-07#Time_of_recent_changes_on_sl_projects

Current discussions

WikiPrevious settingLocal discussion
slwikiEurope/BerlinAlready done, but need to be updated to Europe/Ljubljana
slwikisourceUTChttps://sl.wikisource.org/wiki/Wikivir:Pod_lipo#Anketa_o_sistemskem_.C4.8Dasu
slwikiquoteEurope/BerlinAlready done, but need to be updated to Europe/Ljubljana / https://sl.wikiquote.org/wiki/Wikinavedek:Pod_lipo#Spremenitev_sistemskega_.C4.8Dasa
slwikibooksUTChttps://sl.wikibooks.org/wiki/Wikiknjige:Pod_lipo#Spremenitev_sistemskega_.C4.8Dasa
slwikiversityEurope/LjubljanaAlready done
slwiktionaryUTChttps://sl.wiktionary.org/wiki/Wikislovar:Pod_lipo#Spremenitev_sistemskega_.C4.8Dasa

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2016, 11:15 AM
Restricted Application added subscribers: JEumerus, Matanya. · View Herald TranscriptAug 11 2016, 11:19 AM
Dereckson triaged this task as Normal priority.EditedAug 12 2016, 1:11 AM
Dereckson updated the task description. (Show Details)
Dereckson added a subscriber: Dereckson.

@Janezdrilc So could you start a discussion on sl.wikibooks?

Dereckson updated the task description. (Show Details)Aug 12 2016, 1:14 AM

Change 304423 had a related patch set uploaded (by Dereckson):
Set timezone to Europe/Ljubljana on sl. projects

https://gerrit.wikimedia.org/r/304423

Dereckson claimed this task.EditedAug 12 2016, 1:21 AM

Plan is to deploy this patch this Monday during one of the two available SWAT windows , with a a follow-up change later if/when Slovene Wikibooks community wants to use the timezone too.

There's still Wiktionary to be put on the list for change.

One another thing I noticed is that on all sl projects (including Wikipedia) {{CURRENTTIME}} is set on UTC instead on Europe/Ljubljana. Also other magic words concerning time is good to check (On the Wikipedia's and Wikisource's Main Page there is section "On his day" that is always 2 hours behind in changing templates).

About Wikibooks poll: I believe that no project except Wikipedia and Wikisource is capable to carry out the poll - they have actually no live community:

  • On Wikibooks there's more or less just one active user that is also active on Wikipedia, Wikisource and Wikiversity. He has already voted for change in the Wikisource poll.
  • On Wikiquote it is me that is quite the only one active there.
  • Wiktionary has no active users at all currently.

Wikiquote seems to be using UTC and not Europe/Berlin.

@Dereckson (Forgot to ping you yesterday.)

So, for sl projects with very few contributors, a simple notification to the most logical place for this wiki (for example the village pump) is enough.

Dereckson updated the task description. (Show Details)Aug 13 2016, 7:11 PM
Dereckson updated the task description. (Show Details)Aug 13 2016, 8:21 PM

Thanks. I'm checking what happens for the difference between timezone in config and actual result.

I tested slwikiversity, it's well on UTC+2 currently, so timezone Europe/Ljubljana works fine.

Change 304423 merged by jenkins-bot:
Set timezone to Europe/Ljubljana on sl. projects

https://gerrit.wikimedia.org/r/304423

Mentioned in SAL [2016-08-16T00:17:05Z] <dereckson@tin> Synchronized wmf-config/InitialiseSettings.php: Set timezone to Europe/Ljubljana on sl. projects (T142701) (duration: 00m 49s)

Dereckson updated the task description. (Show Details)Aug 16 2016, 12:19 AM
Dereckson updated the task description. (Show Details)
Dereckson updated the task description. (Show Details)

I updated the table to add a checkmark for wikis done.

@Dereckson Yes, Wikiversity works fine, except {{CURRENTTIME}} is still set on UTC. Is it possible to fix that too?

Are you sure that Wikiquote is currently set on Europe/Berlin? I've just made a test edit and it seems to be set on UTC.

@Dereckson I've checked the {{LOCALTIME}} on all 6 sl projects:

  • It's ok on w, s, q and v
  • b and wikt seems to be on UTC

Okay, perfect, that's coherent with the table in description.

Change 305558 had a related patch set uploaded (by Dereckson):
Set timezone to Europe/Ljubljana on sl. projects

https://gerrit.wikimedia.org/r/305558

Change 305558 merged by jenkins-bot:
Set timezone to Europe/Ljubljana on sl. projects

https://gerrit.wikimedia.org/r/305558

Dereckson closed this task as Resolved.Aug 18 2016, 11:58 PM
Dereckson updated the task description. (Show Details)

@Dereckson Hm, test edits on Wikisource and Wikiquote still show me UTC in recent changes. Wikibooks and Wiktionary are ok now.

Check your preferences: https://sl.wikisource.org/wiki/Posebno:Nastavitve#mw-prefsection-rendering you could have a custom timezone there.

When you want to know default configuration for all users, without any interference from your own preferences, the easiest way is to open a private/incognito tab, so you can check what happens for users logged out.

@Dereckson I checked my preferences:

  • On Wikibooks I've got selected (by default I suppose) Other (specify offset) and recent changes time works fine (UTC+2)
  • On Wikipedia I've got selected Europe/Ljubljana which have been producing UTC+2 in recent changes. Then I changed the option to Other (specify offset) and UTC appeared.

How does the same setting (Other (specify offset)) produce UTC+2 in case of Wikibooks and UTC in case of Wikipedia?

Janezdrilc reopened this task as Open.Aug 23 2016, 10:59 AM
Janezdrilc updated the task description. (Show Details)
Janezdrilc updated the task description. (Show Details)Aug 23 2016, 11:08 AM
Dereckson removed Dereckson as the assignee of this task.EditedAug 23 2016, 12:44 PM
Dereckson removed a project: Patch-For-Review.

Should be checked. But can't reproduce your findings.

Thanks for the synthetic table, that will help to check per wiki and compare behavior.

It really seems it could be dependant of your own preferences. Without being logged in, in private tab:

Both gives me similar result:

  • (prim | zgod) . . Uporabnik:Dereckson/Sandbox‎; 14:46 . . (+24)‎ . . ‎Dereckson (Pogovor | prispevki)‎
  • (prim | zgod) . . Uporabnik:Dereckson/Sandbox‎; 14:47 . . (+10)‎ . . ‎Dereckson (Pogovor | prispevki)‎

Test done at 14:46-7 CEST / 12:46-7 UTC.

Janezdrilc added a comment.EditedAug 23 2016, 2:59 PM

Aha, I see. The usage of time zones in preferences is a little bit confusing. Example for Wikibooks:

  • 1. Time zone is set to Other (specify offset). The field below the selection (where hour should stay) is empty. Recent changes are showing UTC+2.
  • 2. Then I manually select the same option Other (specify offset) and click Save. The fileld is showing +00:00. Recent changes are showing UTC.
  • 3. I select Europe/Ljubljana. Recent changes are showing UTC+2 as expected.
  • 4. I again select Other (specify offset) and manually write in the field +02:00. Recent changes are showing UTC+2.

On Wikiversity for example I didn't touch preferences and the time zone looks ok. The default setting is Other (specify offset) with empty filed below.

So, the problem is that touching the setting makes you unable to reproduce the initial setting (Other (specify offset) with empty filed below).

Dereckson added a comment.EditedAug 23 2016, 6:07 PM

That would be a MediaWiki issue, not a configuration issue, reported as T143713 (where I moved your table).

Dereckson closed this task as Resolved.Aug 23 2016, 6:08 PM
Dereckson claimed this task.

Thanks for creating a new task. Sorry for all inconveniences and misunderstandings too.