Page MenuHomePhabricator

Don't warn about absense of APC on PHP7
Closed, DeclinedPublic

Description

When using the web installer, I get the warning as part of the Environmental checks:

Warning: Could not find APCu, XCache or WinCache.

There is not a APCu package for PHP7, and I understand that PHP7 has a built in cache that means APCu would no longer be useful. If this is the case, can we detect PHP7 and remove the warning?

Event Timeline

Jjanes created this task.Sep 1 2016, 7:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 1 2016, 7:51 PM
Aklapper moved this task from Unsorted to PHP 7 on the [DO NOT USE] NewPHP board.
Krinkle added a subscriber: Krinkle.EditedSep 26 2016, 4:16 PM

I understand that PHP7 has a built in cache that means APCu would no longer be useful.

APC used to be a package providing two features:

  • PHP opcode caching (compilation cache)
  • Object caching (key/value storage)

As of PHP7, opcode caching is a built-in feature and the key/value storage package is now known as APCu. The MediaWiki environmental check is about the key/value storage feature, not the compilation cache. As such, the warning you got seems to be working as intended.

See also https://www.mediawiki.org/wiki/Manual:Performance_tuning.

Reedy added a subscriber: Reedy.Oct 11 2016, 4:19 PM

http://packages.ubuntu.com/xenial/php-apcu

As above, opcode cache is a seperate component now, ala http://packages.ubuntu.com/xenial/php7.0-opcache

I should note MW had some issues handling apcu, but this was fixed in T140587 and T140961, and backported to REL1_27, so will be out in the next point release

Is there anything to actually do here?

Krinkle closed this task as Declined.Oct 11 2016, 11:28 PM

Nope, I think this was just a misunderstanding. @Jjanes Please let us know if there's anything else. Feel free to re-open :)