Page MenuHomePhabricator

Special:MovePage has javascript fatal for pages without talk page
Closed, ResolvedPublic

Description

Error: Widget not found: wpMovetalk-field Error: Widget not found: wpMovetalk-field

wpMovetalk-field is not there for all pages. Pages without a talk page throws this exception on Special:MovePage

It looks like the added lines to the mediawiki.special.movePage.js file in https://gerrit.wikimedia.org/r/#/c/301112/ is the cause for this.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 11 2016, 7:12 AM
matmarex claimed this task.Sep 11 2016, 2:36 PM

Change 309853 had a related patch set uploaded (by Bartosz Dziewoński):
mw.special.movePage: Don't fail if no "Move associated talk page" checkbox

https://gerrit.wikimedia.org/r/309853

matmarex triaged this task as Normal priority.Sep 11 2016, 5:21 PM
Jdforrester-WMF closed this task as Resolved.Sep 12 2016, 3:34 PM

Change 309853 merged by jenkins-bot:
mw.special.movePage: Don't fail if no "Move associated talk page" checkbox

https://gerrit.wikimedia.org/r/309853