Page MenuHomePhabricator

Remove reference to the jump-text parameter from the poll creation page
Closed, ResolvedPublic

Description

After you submit the form on poll creation page, a PHP warning is shown as follows:

Notice:  Undefined index: jump-text in /var/www/html/extensions/SecurePoll/includes/pages/CreatePage.php on line 971

The root cause is that the election parameter jump-text is only available on the poll translation page (not on the poll creation page). It makes perfect sense because the jump text is different for each language (it is supposed to be translated).

Solution would be to remove the reference to jump-text in the poll creation page, where it doesn't belong and is not used.

Details

Related Gerrit Patches:

Event Timeline

Huji created this task.Sep 14 2016, 4:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 14 2016, 4:02 PM
Huji claimed this task.Sep 14 2016, 4:02 PM
Huji triaged this task as Lowest priority.

Notifying @tstarling and @Anomie because the reference to jump-url was first added by them in rESPO6c82435085c3

It is perplexing because code is added to receive the jump-url property from the submitted form, but the CreatePage form doesn't have a field with that name (never did).

Huji renamed this task from Undefined index: jump-text to Remove reference to the jump-text parameter from the poll creation page.Oct 12 2016, 2:48 PM
Huji updated the task description. (Show Details)

Change 315514 had a related patch set uploaded (by Huji):
Remove reference to the jump-text parameter from the poll creation page

https://gerrit.wikimedia.org/r/315514

Change 315514 merged by jenkins-bot:
Remove reference to the jump-text parameter from the poll creation page

https://gerrit.wikimedia.org/r/315514

Huji closed this task as Resolved.Oct 13 2016, 12:50 AM