Page MenuHomePhabricator

SecurePoll not recording votes on vote wiki anymore
Closed, ResolvedPublic

Description

I just tried to re-vote in an ongoing election on https://vote.wikimedia.org and when I submitted my vote I got a blank page. Since I don't have access to WMF server logs I cannot tell what went wrong. The election is ongoing so immediate action is needed. I will mark this as high priority.

It might make sense for now to revert the SecurePoll on that server to the last working version (it worked fine until 9/19) while we figure out what went wrong.

We will also need a WMF server admin to look at the logs and tell us what the error message was. I don't know how to get their attention on Phabricator. I will send an email to wikitech-l just in case.

Event Timeline

Huji created this task.Sep 23 2016, 1:42 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2016, 1:42 AM
Huji triaged this task as High priority.Sep 23 2016, 1:42 AM
MaxSem added a subscriber: MaxSem.Sep 23 2016, 2:01 AM
2016-09-22 21:16:55 [V@RKRgpAMFcAAIoXUUcAAAAQ] mw1252 votewiki 1.28.0-wmf.20 fatal ERROR: [7712aab1] PHP Fatal Error: Call to undefined method Status::__
construct() {"exception_id":"7712aab1"}
[Exception ErrorException] (/srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/ballots/Ballot.php:270) PHP Fatal Error: Call to undefined method Status::__construct()
  #0 /srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/ballots/Ballot.php(270): NO_FUNCTION_GIVEN()
  #1 /srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/ballots/Ballot.php(86): SecurePoll_BallotStatus->__construct(SecurePoll_Context)
  #2 /srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/pages/VotePage.php(137): SecurePoll_Ballot->submitForm()
  #3 /srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/pages/VotePage.php(90): SecurePoll_VotePage->doSubmit()
  #4 /srv/mediawiki/php-1.28.0-wmf.20/extensions/SecurePoll/includes/main/SpecialSecurePoll.php(68): SecurePoll_VotePage->execute(array)
  #5 /srv/mediawiki/php-1.28.0-wmf.20/includes/specialpage/SpecialPage.php(522): SecurePoll_SpecialSecurePoll->execute(string)
  #6 /srv/mediawiki/php-1.28.0-wmf.20/includes/specialpage/SpecialPageFactory.php(584): SpecialPage->run(string)
  #7 /srv/mediawiki/php-1.28.0-wmf.20/includes/MediaWiki.php(283): SpecialPageFactory::executePath(Title, RequestContext)
  #8 /srv/mediawiki/php-1.28.0-wmf.20/includes/MediaWiki.php(861): MediaWiki->performRequest()
  #9 /srv/mediawiki/php-1.28.0-wmf.20/includes/MediaWiki.php(522): MediaWiki->main()
  #10 /srv/mediawiki/php-1.28.0-wmf.20/index.php(43): MediaWiki->run()
  #11 /srv/mediawiki/w/index.php(3): include(string)
  #12 {main}

Change 312449 had a related patch set uploaded (by MaxSem):
Fix fatal

https://gerrit.wikimedia.org/r/312449

Change 312449 merged by jenkins-bot:
Fix fatal

https://gerrit.wikimedia.org/r/312449

Change 312450 had a related patch set uploaded (by MaxSem):
Fix fatal

https://gerrit.wikimedia.org/r/312450

Tgr added a subscriber: Tgr.Sep 23 2016, 2:10 AM

Caused by c64c3ef9a8, probably.

Change 312450 merged by jenkins-bot:
Fix fatal

https://gerrit.wikimedia.org/r/312450

MaxSem closed this task as Resolved.Sep 23 2016, 2:14 AM
MaxSem claimed this task.

Fix deployed.

Tgr added a comment.Sep 23 2016, 2:16 AM

(Did a quick grep and this seems to be the only extension in gerrit that extends Status.)

Huji added a comment.Sep 23 2016, 2:06 PM

Thanks Max!