Page MenuHomePhabricator

VisualEditor upload wizard prevents me from uploading and leaves me at dead-end dialog
Closed, InvalidPublic

Description

Steps to reproduce:

  • Edit a page using VE
  • Insert media
  • Upload a file (attached)
  • Fill in metadata
    • Name: Generic import spreadsheet tooltip
    • Description: Screenshot of documentation
    • Categories: Screenshot; Fundraising
  • Submit

I get a dialog saying that the system cannot tell if this is acceptable for upload to commons. I'm left stuck in the upload dialog with a disabled submit button, and my only choice is to cancel. Very unpleasant UX.

The file which caused this is attached:

Full text of the abuse dialog (yes, it was not rendered into HTML):

{| style="width:100%; padding:1px 4px; border:1px solid #bb7070; background:#ffdbdb;" | style="text-align:center; width:60px;" |[[File:Dialog-error.svg|50px|link=|Your action has triggered the Abuse Filter]] | An automated filter has identified this edit as potentially unconstructive, and it has been disallowed. If this edit is constructive, please [[Commons:Abuse filter#False positives|report this error]]. |}

A third attempt gives me this dialog, same UX:

We could not determine whether this file is suitable for Wikimedia Commons. Please only upload photos that you took yourself with your camera, or see what else is acceptable. See the guide to make sure the file is acceptable and learn how to upload it on Wikimedia Commons.

FF 45.3.0, linux

Event Timeline

awight created this task.Sep 28 2016, 8:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 28 2016, 8:34 PM
awight updated the task description. (Show Details)Sep 28 2016, 8:38 PM
awight updated the task description. (Show Details)Sep 28 2016, 8:40 PM
matmarex closed this task as Invalid.Sep 30 2016, 12:03 AM
matmarex added a project: MediaWiki-Uploading.
matmarex added a subscriber: matmarex.

This is basically intentional. The filter linked by @Schnark is meant to block files like this when uploaded using the cross-wiki upload dialog, in response to numerous similar uploads by new users which were largely copyright violations (you can read the saga at T120867). You should be able to upload it directly on Commons: https://commons.wikimedia.org/wiki/Special:UploadWizard.

As for specific interface issues:

I'm left stuck in the upload dialog with a disabled submit button, and my only choice is to cancel. Very unpleasant UX.

We kind of fixed this recently in T114938, which will turn the "Cancel" into a "Back".

Full text of the abuse dialog (yes, it was not rendered into HTML):

This is the generic text which is normally not used by any of the upload filters; however, it is displayed on every other prevented upload attempt due to T27086. There is a patch pending there which would allow this to be resolved, I would appreciate help in getting it merged.

Restricted Application added a project: Multimedia. · View Herald TranscriptSep 30 2016, 12:03 AM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptSep 30 2016, 12:06 AM