Page MenuHomePhabricator

Searching for words with two letters does not work
Closed, ResolvedPublic

Description

To reproduce:

  • Click the Phabricator logo at the top.
  • Click "Maniphest".
  • Click "Advanced Search".
  • Put "Amire80" in "Authors".
  • Put "H1" in "Contains Words".
  • Click "Search".

Observed:

  • "No tasks found".

Expected:

Event Timeline

Amire80 created this task.Dec 16 2016, 9:21 AM
Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptDec 16 2016, 9:21 AM
Paladox added a subscriber: Paladox.EditedDec 16 2016, 11:05 AM

Hi You carnt search for H1 in the advanced search bar because you are limited to 3 words or higher so for example if you had H11 then searching for H11 will work. Searching for H1 won't work as it is two words.

Your word minimum is three words or higher.

Aklapper renamed this task from A task cannot be found by the word "H1", even though it appears in the title to Searching for words with two letters does not work.Dec 16 2016, 11:10 AM
Aklapper triaged this task as Lowest priority.

So... can it be changed? A search for a title with h1 is totally legitimate. I was sure I reported that bug and couldn't find it for maybe ten minutes using Phab's search, and then I found it using Google site search in ten seconds. If it's good for Google, why wouldn't it good for Phabricator?

Yep it can with a simple change to a mysql innodb config and then a reindex.

I've submitted a patch here https://gerrit.wikimedia.org/r/#/c/315057/ that currently has -1.

Related task T146843

Doint forget google has a very advanced search bar so it will be very much more better then phabricator's.

Paladox closed this task as Resolved.Jun 4 2017, 2:26 PM

Works for me https://phabricator.wikimedia.org/maniphest/query/bJfAQGu3mhNw/#R now. Since we switched to elasticsearch.