Page MenuHomePhabricator

Update Extension:Newsletter page for administrators
Closed, ResolvedPublic

Description

https://www.mediawiki.org/wiki/Extension:Newsletter looks like a pretty decent extension page, but
we have worked a lot on that extension after the bulk of that page was written. It needs verification. Is the information in that page up to date? Is there key information that is missing?

In order to complete this task properly, you should have a clean MediaWiki 1.27+ installation and proceed to install the extension following the instructions in that page. Then you should check that any pages/features described are correct.

Note that the audience for that page are wiki administrators. Help documentation will be found in another page (see T154222: Create Newsletter Extension Help page).

Although I can help proxy-mentoring this task for Google-Code-In-2016, I would feel more comfortable if @01tonythomas is the person who actually evaluates the task, since he knows the tech involved, dependencies, etc.

Event Timeline

QuimGil created this task.Dec 28 2016, 8:26 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 28 2016, 8:26 AM
Peachey88 renamed this task from Verify https://www.mediawiki.org/wiki/Extension:Newsletter to Verify https://www.mediawiki.org/wiki/Extension:Newsletter contains up-to date information.Dec 28 2016, 8:56 AM
Aklapper updated the task description. (Show Details)Dec 28 2016, 10:10 PM
Aklapper moved this task from Proposed tasks to Missing mentors on the Google-Code-In-2016 board.

I can mentor this along with @Qgil. Lets make it into the GCI baoard!

Aklapper renamed this task from Verify https://www.mediawiki.org/wiki/Extension:Newsletter contains up-to date information to Verify Extension:Newsletter homepage for administrators contains up-to date information.Jan 4 2017, 5:40 PM
Qgil triaged this task as Normal priority.Sep 6 2017, 9:41 PM
QuimGil renamed this task from Verify Extension:Newsletter homepage for administrators contains up-to date information to Update Extension:Newsletter page for administrators.Sep 7 2017, 8:04 PM
QuimGil moved this task from Backlog to Confirmed on the MediaWiki-extensions-Newsletter board.

Although most of the page holds, there are things that need to be updated. For instance, the Manage newsletter information needs updating. The View subscribers part too. I haven't looked in detail.

01tonythomas closed this task as Resolved.Oct 28 2018, 4:43 PM
01tonythomas claimed this task.

I think should be done at this point. I added some #CONTRIBUTING docs too for the Mozilla program.