Page MenuHomePhabricator

[regression pre-wmf.9] Clicking on notification badges gives TypeError
Closed, ResolvedPublic

Description

In betalabs click on any of Notifications badges - the drop-down panel is not displayed; a user is redirected to Special:Notifications page, and the Console shows the following:

TypeError: mw.echo.ui.messageWidget.badgeButton.debouncedUpdateThemeClasses is not a function TypeError: mw.echo.ui.messageWidget.badgeButton.debouncedUpdateThemeClasses is not a function(…)

Also,
GET http://sentry-beta.wmflabs.org/api/4/store/?sentry_version=4&sentry_client=…desktop%22%7D%2C%22event_id%22%3A%229f9828c1a30d4a108111120178132ada%22%7D 502 (Bad Gateway)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 20 2017, 1:14 AM
Etonkovidova updated the task description. (Show Details)Jan 20 2017, 1:17 AM

Change 333269 had a related patch set uploaded (by Sbisson):
Remove calls to debouncedUpdateThemeClasses

https://gerrit.wikimedia.org/r/333269

I've +2'ed the commit to make sure the regression is fixed asap - also the fix works well and I couldn't spot any issues with it in vector or monobook.

However, copying my comment from the gerrit commit for posterity:

"debouncedUpdateThemeClasses" was inserted to fix loading issues in monobook, because monobook uses Apex theme, and the icons and CSS were loaded too late (the icon used to "flash" for a split second when loading the page in monobook)
Since the method doesn't exist, it's clearly irrelevant anymore; from my brief testing in vector and monobook I couldn't spot any immediate issues and monobook seems to load correctly. I'm +2'ing this, but we should keep this in mind in case we have a regression of loading in monobook in the near future.

As I said, local tests didn't reveal loading issues in monobook, but let's keep an eye out for this, since that was the purpose of using debounceUpdateThemeClasses hack.

Change 333269 merged by jenkins-bot:
Remove calls to debouncedUpdateThemeClasses

https://gerrit.wikimedia.org/r/333269

Etonkovidova added a comment.EditedJan 24 2017, 12:03 AM

Checked the fix in betalabs (in monobook too).

QA recommendation: Resolve.

jmatazzoni closed this task as Resolved.Jan 24 2017, 1:56 AM