Page MenuHomePhabricator

RC filters - 'Highlight results' button is still active even with 'No filters found'
Closed, ResolvedPublic

Description

  1. In the Filter search box enter some text that will not return filter suggestions.
  2. 'No filters found' will be displayed but 'Highlight results' button can be clicked. When it's clicked, the bullet points are displayed blank.

There is a minor implication - if some other filters were selected with highlighting and the search was made for a filter that did not turn any results, and the 'Highlight results' button is clicked, then the highlighting will be lost for all filters.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 18 2017, 10:36 PM

Another thing that happens when you click the highlight button (whether or not filters are displayed) is that the results all indent. They all move to the right about a quarter inch. Is that intentional?

Change 349102 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters UI: Unify li bullets with and without highlights

https://gerrit.wikimedia.org/r/349102

The fix above is about @jmatazzoni's observation regarding the "moving" text when switching highlight on/off.

Regarding the source of the ticket - I don't think this is a bug. The "Highlight" button speaks to whether, in general, highlighting is on or off. The fact that in the current filter-search you have no results doesn't change that fact.

For example, if you already have a couple of highlighted filters (with highlights in the list) and then you search for another filter, even if there's no results, the highlights are still active. That's intended.
"Highlight results" is a general toggle of whether or not there can (or are) highlights, in general, on the current results - while the filter search is a temporary action to find a filter. We don't shut off the highlighting feature at that time.

I don't see a bug here, unless I'm missing something?

jmatazzoni closed this task as Resolved.Apr 20 2017, 6:43 PM
jmatazzoni claimed this task.

I agree that this is expected behavior, if I understand the ticket properly. Meanwhile, Elena said she created a new task for the alignment change (that Moriel says she's fixed already), so I'm closing this. @Etonkovidova, please let us know if we're missing the point.

Change 349102 merged by jenkins-bot:
[mediawiki/core@master] RCFilters UI: Unify li bullets with and without highlights

https://gerrit.wikimedia.org/r/349102