Page MenuHomePhabricator

[bug] Namespaces for "Page" and "Index" in the Norwegian Wikisource are suddenly in English
Closed, ResolvedPublic

Description

The namespaces used to be translated into Norwegian, but they are now suddenly in English. This make all links to pages in these namespaces redlinks.

The correct translation for "Page" is "Side", and the translation for "Index" is "Indeks".

Event Timeline

jhsoby created this task.Apr 23 2017, 7:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 23 2017, 7:39 PM
jhsoby triaged this task as Unbreak Now! priority.Apr 23 2017, 7:39 PM
Restricted Application added subscribers: Jay8g, TerraCodes, Dereckson. · View Herald TranscriptApr 23 2017, 7:39 PM
Dereckson lowered the priority of this task from Unbreak Now! to High.EditedApr 23 2017, 9:00 PM
Dereckson moved this task from Backlog to Config - to process on the Wikimedia-Site-requests board.
Dereckson edited projects, added ProofreadPage; removed MediaWiki-Internationalization.

We recently cleaned up namespaces to move translations to the extension code.

To fix that I'm going to:

  • add back in the Wikimedia config the namespaces (temporarily)
  • add localisation in the extension code
  • when localisation is done in the extension code, removed the temporary config readd

Or perhaps directly fix at extension level.

Is that acceptable to wait Monday 15:00 for deployment or do you consider this is an emergency and we should do that now (I'd have imagined this is an emergency, please note you're reporting this 11 days afterwards, so I'm a little bit reluctant to deploy outside hours, something strongly discouraged by current deployment practices)?

[ Decreasing a little bit the priority, as the site still works. ]

Thanks! I was just made aware of this today, but it's not an immediate emergency (sorry if I was wrong to use the Unbreak now priority!), however I think it should be fixed quickly since all links to those namespaces are broken. But waiting until tomorrow should be fine, the site isn't that high-traffic.

Is there anything I can do to help with the localisation part?

Dereckson added a comment.EditedApr 23 2017, 10:59 PM

Oh, actually the issue is easy, wiki language is nb, but 98bb4405 added it as no to extension code, so when the configuration was cleaned up to use instead this extension localisation, we lost the nb one.

Change 349863 had a related patch set uploaded (by Dereckson):
[mediawiki/extensions/ProofreadPage@master] Fix language code for Norwegian

https://gerrit.wikimedia.org/r/349863

Dereckson moved this task from Backlog to Top priority on the ProofreadPage board.
Dereckson moved this task from Backlog to Next-up on the Wikisource board.

Change 349863 merged by jenkins-bot:
[mediawiki/extensions/ProofreadPage@master] Fix language code for Norwegian

https://gerrit.wikimedia.org/r/349863

Dereckson moved this task from Top priority to Done on the ProofreadPage board.Apr 24 2017, 8:16 AM

Extension code has been fixed, it will be shipped with 1.29.0-wmf.21. Meanwhile, I'll deploy the fix to 1.29.0-wmf.20 at the next EU SWAT.

Dereckson closed this task as Resolved.Apr 24 2017, 2:30 PM
Dereckson claimed this task.

Change has been backported to 1.29.0-wmf.20. Works.

Thank you very much for a swift solution, @Dereckson!

  1. apr. 2017 16:31 skrev "Dereckson" <no-reply@phabricator.wikimedia.org>:

Dereckson closed this task as "Resolved".
Dereckson claimed this task.
Dereckson added a comment.
Change has been backported to 1.29.0-wmf.20. Works.
*TASK DETAIL*
https://phabricator.wikimedia.org/T163647
*EMAIL PREFERENCES*
https://phabricator.wikimedia.org/settings/panel/emailpreferences/
*To: *Dereckson
*Cc: *gerritbot, Dereckson, TerraCodes, Jay8g, jhsoby, Aklapper,
Adik2382, Th3d3v1ls, Ramalepe, Liugev6, Lewizho99, Maathavan, Tshrinivasan,
Urbanecm, JEumerus, Info-farmer, Samwilson, Tulsi_Bhagat, MGChecker,
Luke081515, biplabanand, Snowolf, jayvdb, Shizhao, Tpt, Billinghurst,
Matanya, jayantanth, Rxy, Krenair

You're welcome.