Page MenuHomePhabricator

Warning: onEnhancedChangesListModifyBlockLineData() expects exactly 4 parameters, 3 given in /srv/mediawiki/php-1.29.0-wmf.21/extensions/Flow/Hooks.php on line 538
Closed, ResolvedPublic

Description

seen in logstash for wmf/1.29.0-wmf.21

also see:

Notice: Undefined variable: classes in /srv/mediawiki/php-1.29.0-wmf.21/extensions/Flow/Hooks.php on line 553

Details

Related Gerrit Patches:
mediawiki/extensions/Flow : wmf/1.29.0-wmf.21Make onEnhancedChangesListModifyBlockLineData expect 3 args
mediawiki/extensions/Flow : masterMake onEnhancedChangesListModifyBlockLineData expect 3 args

Event Timeline

aude created this task.Apr 26 2017, 1:38 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 26 2017, 1:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Mentioned in SAL (#wikimedia-operations) [2017-04-26T19:42:15Z] <twentyafterfour> rolling back group1 to wmf.20 due to T163896 refs T161733

mmodell triaged this task as High priority.Apr 26 2017, 7:42 PM
mmodell added a subscriber: mmodell.

this is happening A LOT after promoting group1. Rolling back to wmf.20, this is now a blocker for the wmf.21 train to proceed.

I'm still trying to track down where the 3-arg call is coming from - I don't see any code that calls that method with 3 args.

SBisson claimed this task.Apr 26 2017, 8:02 PM
SBisson added a subscriber: SBisson.

includes/changes/EnhancedChangesList.php:670 is calling the 'EnhancedChangesListModifyBlockLineData' hook with 3 args

We introduced this problem with a change in Flow recently. I'll fix it.

Change 350477 had a related patch set uploaded (by Sbisson):
[mediawiki/extensions/Flow@master] Make onEnhancedChangesListModifyBlockLineData expect 3 args

https://gerrit.wikimedia.org/r/350477

Change 350477 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Make onEnhancedChangesListModifyBlockLineData expect 3 args

https://gerrit.wikimedia.org/r/350477

Change 350481 had a related patch set uploaded (by 20after4; owner: Sbisson):
[mediawiki/extensions/Flow@wmf/1.29.0-wmf.21] Make onEnhancedChangesListModifyBlockLineData expect 3 args

https://gerrit.wikimedia.org/r/350481

Change 350481 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.29.0-wmf.21] Make onEnhancedChangesListModifyBlockLineData expect 3 args

https://gerrit.wikimedia.org/r/350481

Mentioned in SAL (#wikimedia-operations) [2017-04-26T21:07:59Z] <twentyafterfour@naos> Synchronized php-1.29.0-wmf.21/extensions/Flow/Hooks.php: sync https://gerrit.wikimedia.org/r/#/c/350481/ refs T163896 T161733 (duration: 01m 20s)

mmodell closed this task as Resolved.Apr 26 2017, 9:14 PM

deployed to wmf.21 and confirmed fixed.

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:10 PM