Page MenuHomePhabricator

Unblock EPFL IP addresses for access to IRC
Closed, ResolvedPublic

Description

I'm working with a student in École polytechnique fédérale de Lausanne and they cannot use the university network to connect to Wikimedia IRC channels. This may be an IP ban issue as the student can connect to non-Wikimedia channels on IRC. One example of an IP address that won't allow him to connect is: 128.179.254.56

Event Timeline

leila created this task.May 6 2017, 7:22 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 6 2017, 7:22 PM
Legoktm added a subscriber: Legoktm.May 6 2017, 7:34 PM

Are these Wikimedia IRC channels on irc.freenode.net or irc.wikimedia.org?

The problem is on irc.freenode.net:

[21:24:15] tizianop sets mode +Zi
[21:24:21] Message(474): Cloud-Services Cannot join channel (+b) - you are banned
[21:24:21] Message(474): Research Cannot join channel (+b) - you are banned
[21:24:21] Message(474): #wikimedia Cannot join channel (+b) - you are banned
[21:24:21] Message(474): #wikimedia-tech Cannot join channel (+b) - you are banned

DatGuy added a subscriber: DatGuy.May 6 2017, 9:07 PM

Not sure if this should have a phab ticket. Nevertheless, what is your full mask (x!y@z)?

~tizianop@tsf-452-wpa-3-252.epfl.ch but all the mask *@*.epfl.ch seems banned.

Thanks

*!*@*.ch on Thu Apr 20 11:01:39 2017 by c!~charitwo@wikimedia/charitwo

Would be the relevant global ban

Danilo claimed this task.May 6 2017, 10:13 PM
Danilo added a subscriber: Danilo.

@tizianopiccardi, AlexZ unbanned *!*@*.ch, can you confirm if you can join channels now?

Danilo removed Danilo as the assignee of this task.May 6 2017, 10:21 PM
tizianopiccardi closed this task as Resolved.May 6 2017, 10:24 PM
tizianopiccardi claimed this task.

Solved. Thanks