Deploy InternetArchiveBot on the Italian Wikipedia (itwiki)
Closed, ResolvedPublic

Description

The Italian Wikipedia is the 8th largest Wikipedia and has a significant number of external links.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 7 2017, 8:11 PM
Cyberpower678 triaged this task as High priority.May 7 2017, 8:11 PM
Moroboshi added a comment.EditedMay 8 2017, 7:57 AM

Hello, I'm looking at the bot configuration. I see that the parameter "citation_tags" is used to specify citation template names (for example "Cita libro" on it.wiki instead of "Cite book" on en.wiki), but how I indicate the parameters name ? For example parameter "archive-url" on en.wiki is called "urlarchivio" on it.wiki.

Bultro added a subscriber: Bultro.May 8 2017, 11:00 AM

Hello, I'm looking at the bot configuration. I see that the parameter "citation_tags" is used to specify citation template names (for example "Cita libro" on it.wiki instead of "Cite book" on en.wiki), but how I indicate the parameters name ? For example parameter "archive-url" on en.wiki is called "urlarchivio" on it.wiki.

The citation parameters are built into the code directly when the bot is being extended onto a new wiki. Before deploying I do heavy research, but I will appreciate any insight where I should be looking to make my job easier. :-)

Lucas added a subscriber: Lucas.May 8 2017, 3:41 PM
Lucas added a comment.EditedMay 8 2017, 3:47 PM

Here you can find the it.wiki citation templates: https://it.wikipedia.org/wiki/Categoria:Template_citazione_fonti .

I think I'd add a "webarchive" parameter here and there, if needed.

Please leave a line if you need any kind of help. ;)

Lucas added a comment.May 9 2017, 5:52 AM

Hello. Another question: where can I help in translating all the bot messages?

The following template (or redirect to template) are compatibility template for text translated from en.wiki, parameters names are the same as en.wiki (a bot translate them to the it.wiki format): Cite web, Citeweb, Cite press release, Cite book, Cite news, Cite journal, Cite paper, Cite conference, Cite document, Cite video

The following template: Lien web, Ouvrage are compatibility template for text translated from en.wiki, parameters names are the same as fr.wiki (there also translated to it.wiki format by a bot)

The following template: Cita libro, Cita news, Cita testo, Cita conferenza, Cita pubblicazione, Cita web, Cita video, Cita TV are a localization of the citation template of en.wiki. Url parameters name are the following (on the left the it.wiki name, on the right the en.wiki name)
url or URL → url
urlarchivio → archive-url
dataarchivio → archive-date
urlmorto → dead-url value of "no" means the original url is not dead
urlcapitolo → chapter-url
Note there are also urlarchivio2 and dataarchivio2 parameters (it was requested the possibility to cite two different archive)

Beta16 added a subscriber: Beta16.May 10 2017, 8:05 AM

@Lucas can you point me to bot approvals?

Open a request on https://it.wikipedia.org/wiki/Wikipedia:Bot/Autorizzazioni they are english instructions on the right

@Moroboshi There doesn't seem to be any activity on my request. Am I missing something?

@Cyberpower678 Approval procedure on it.wiki require that new bot do about 50 edits to verify their contributions (point 3 of instruction on the page) and wait for a Bureaucrats to give the bot flag.

Ah. So I start trial right away rather than wait for someone to approve for trial. I will trial it when I can.

Hello. Another question: where can I help in translating all the bot messages?

@Lucas The tool interface can be translated at https://translatewiki.net/w/i.php?title=Special:Translate&group=internetarchivebot&language=it

I could use some translations for the following list of text.

  • External links modified
  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.
  • External links found that need fixing
  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.
  • Trouble archiving links on the article
  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.
  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.
  • {link} is found to be dead. No archive was found.
  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.
  • Added archive {newarchive} to {link}
  • Replaced archive link {oldarchive} with {newarchive} on {link}
  • Corrected formatting/usage for {link}
  • Added {{tlx|dead link}} tag to {link}
  • Removed dead tag from {link}
  • Modified source for {link}
  • {problem} with error {error}
  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.
  • Notification of errors encountered when attempting to archive links
  • Notification of altered sources needing review

Does itwiki have any archive templates like enwiki's {{Webarchive}}?

Aside from the translations, the bot is ready for testing but it can't edit. It's hitting the captcha.

Does itwiki have any archive templates like enwiki's {{Webarchive}}?

I'm not aware of an equivalent of :en:template:Webarchive, but I can import it to it.wiki.

Aside from the translations, the bot is ready for testing but it can't edit. It's hitting the captcha.

The bot must be flagged as bot to run or can be run manually from a normal account ?

@Cyberpower678 I have imported webarchive to italian wiki (will localize in the next day but It will work also with the english parameter name (title, date,...)

Aside from the translations, the bot is ready for testing but it can't edit. It's hitting the captcha.

The bot must be flagged as bot to run or can be run manually from a normal account ?

The bot is fully automatic. So it's difficult to run manually. I would need the bot flag, or at least confirmed.

Hello. Another question: where can I help in translating all the bot messages?

@Lucas The tool interface can be translated at https://translatewiki.net/w/i.php?title=Special:Translate&group=internetarchivebot&language=it

I could use some translations for the following list of text.

  • External links modified
  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.
  • External links found that need fixing
  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.
  • Trouble archiving links on the article
  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.
  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.
  • {link} is found to be dead. No archive was found.
  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.
  • Added archive {newarchive} to {link}
  • Replaced archive link {oldarchive} with {newarchive} on {link}
  • Corrected formatting/usage for {link}
  • Added {{tlx|dead link}} tag to {link}
  • Removed dead tag from {link}
  • Modified source for {link}
  • {problem} with error {error}
  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.
  • Notification of errors encountered when attempting to archive links
  • Notification of altered sources needing review

@Lucas, just in case you missed it since it ran off of the thread, can you provide translations for the text I quoted.

@Cyberpower678 I have imported webarchive to italian wiki (will localize in the next day but It will work also with the english parameter name (title, date,...)

You didn't have to, but okay.

I just need the translations, and I can run the bot to trial it.

I could use some translations for the following list of text.

  • External links modified

Collegamenti esterni modificati

  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.

Gentile utenti,\n\nho appena modificato {linksrescued} collegamenti esterni sulla pagina [[{namespacepage}]]. Per cortesia controllate la [{diff} mia modifica]. Se avete qualche domanda o se fosse necessario far sì che il bot ignori i link o l'intera pagina, date un'occhiata a [[:m:InternetArchiveBot/FAQ|queste FAQ]]. Ho fatto le seguenti modifiche:\n{modifiedlinks}\nFate riferimenti alle FAQ per informazioni su come correggere gli errori del bot\n\nSaluti.

  • External links found that need fixing

Collegamenti esterni che necessitano di correzione

  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.
  • Gentili utenti,\n\nHo individuato uno o più collegamenti esterni su [[{namespacepage}]] che necessitano di attenzione. Per cortesia verificate i link trovati e correggeteli se necessario. Ho trovato i seguenti problemi:\n{modifiedlinks}\nUna volta completate le modifiche necessarie visitate [[:m:InternetArchiveBot/FAQ|le FAQ]] per sapere come correggere eventuali problemi coi link in questione.\n\nQuesta notifica sarà data una volta sola per questi URL.\n\nSaluti.
  • Trouble archiving links on the article
  • Problemi durante l'archiviazione dei link sulla voce.
  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.
  • Ciao, durante il processo di archiviazione l'archivio ha restituito degli errorei per uno o più siti.\nDi seguito i collegamenti che hanno dato un errore con l'errore restituito.\n\n{problematiclinks}\nIn ogni caso questa sarà l'unico messaggio d'errore per questi specifici link e non ci saranno ulteriori tentativi d'archiviazione.\n\nSaluti.
  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.
  • {link} è interrotto. Si raccomanda l'aggiunta di {newarchive} all'URL originale
  • {link} is found to be dead. No archive was found.
  • {link} è interrotto e non ne è stata trovata una versione archiviata.
  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.
  • {link} è marcato come interrotto, tuttavia sembra funzionare. Si raccomanda di rimuovere la marcatura "interrotto" dall'URL.
  • Added archive {newarchive} to {link}
  • Aggiunta del link all'archivio {newarchive} per {link}
  • Replaced archive link {oldarchive} with {newarchive} on {link}
  • Sostituzione del link all'archivio {oldarchive} con {newarchive}su {link}
  • Corrected formatting/usage for {link}
  • Correzione formattazione/utilizzo di {link}
  • Added {{tlx|dead link}} tag to {link}
  • Aggiunta di {{tl|collegamento interrotto}} su {link}
  • Removed dead tag from {link}
  • Rimozione del tag link interrotto da {link}
  • Modified source for {link}
  • Fonte modificata per {link}
  • {problem} with error {error}
  • {problem} con errore {error}
  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.
  • Recupero di {linksrescued} fonti e segnalazione di {linkstagged} link interrotti.
  • Notification of errors encountered when attempting to archive links
  • Notifica di errori durante l'archiviazione dei link
  • Notification of altered sources needing review
  • Notifica di fonti modificate che necessitano di una revisione
Lucas added a comment.Aug 4 2017, 12:33 PM

Nice translation, there is just a couple of typos in the following message, that I'd review this way:

Ciao, durante il processo di archiviazione l'archivio ha restituito degli errori per uno o più siti.\nDi seguito i collegamenti che hanno dato errore e il relativo errore restituito.\n\n{problematiclinks}\nIn ogni caso, questa sarà l'unica notifica inerente questi specifici link, e non ci saranno ulteriori tentativi d'archiviazione.\n\nSaluti.

cheers ;)

Translations installed. Beginning bot trial.

Lucas added a comment.Aug 8 2017, 12:21 PM

@Cyberpower678 thank you very much for your tool and your implementation. ;)

In a couple of days Vito (or another bureaucrat) will set the flag (point 4: "after about one week from the request a bureaucrat will give the flag"). When ready, would you please add the it.wiki option to the tool in the drop down menu? To generate links like:

https://tools.wmflabs.org/iabot/index.php?page=runbotsingle&pagesearch=Roma&wiki=itwiki

Thanks again.

Vituzzu closed this task as Resolved.Aug 8 2017, 1:06 PM
Cyberpower678 reopened this task as Open.Aug 8 2017, 1:07 PM

Not quite yet. ;)

Bot is awaiting final deployment on production servers.

Cyberpower678 closed this task as Resolved.Sat, Sep 2, 8:32 PM

Deployed