Page MenuHomePhabricator

Allow admins to choose which branch(es) are said by wm-bot on IRC
Open, LowPublic

Description

When wm-bot is set up on a GitHub repository, it appears to listen to all branches on the remote repository. It would be very useful to be able to opt out of listening to specific branches. Here is what I propose:

@github-branch- <branch> wm-bot would not say any more commits from that branch to the channel
@github-branch+ <branch wm-bot would say commits to the branch again (undoes the above)
@github-branch-only <branch> wm-bot would only say commits to <branch>
@github-branch-all wm-bot would say commits to all branches. Resets all of the above.

By default, wm-bot would listen to all branches, which is the current behavior.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 4:06 PM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM
Restricted Application added a project: User-Matthewrbowker. · View Herald TranscriptNov 5 2017, 7:34 PM
Petrb triaged this task as Low priority.Nov 5 2017, 7:36 PM
Petrb removed Petrb as the assignee of this task.Mar 24 2020, 11:59 PM
Petrb added a subscriber: Petrb.
MacFan4000 moved this task from Unsorted to Feature request on the WM-Bot board.Apr 28 2020, 1:20 AM