Page MenuHomePhabricator

Flow is broken on frwikiquote due to local JavaScript in MediaWiki:Common.js
Closed, ResolvedPublic

Description

Reported on frwikiquote
Can be tested here : https://fr.wikiquote.org/w/index.php?title=Discussion_utilisateur:Lykos&safemode=1 by trying to create a new topic. Present for me on https://fr.wikiquote.org/wiki/Discussion_utilisateur:Trizek_(WMF) too.
Problem is present when I'm not connected (IP) too
Cannot reproduce on wikipedia
It works by using the API (pywikbiot), so it's a JS problem.

On the console:

Exception in module-execute in module site:
ReferenceError: hookEvent is not defined ReferenceError: hookEvent is not defined
logError https://fr.wikiquote.org/w/load.php:176:53
	handler https://fr.wikiquote.org/w/load.php:154:832
	fire https://fr.wikiquote.org/w/load.php:45:104
	fireWith https://fr.wikiquote.org/w/load.php:46:431
	fire https://fr.wikiquote.org/w/load.php:46:474
	track https://fr.wikiquote.org/w/load.php:154:614
	runScript/< https://fr.wikiquote.org/w/load.php:161:301
	fire https://fr.wikiquote.org/w/load.php:45:104
	add https://fr.wikiquote.org/w/load.php:45:656
	always https://fr.wikiquote.org/w/load.php:46:865
	runScript https://fr.wikiquote.org/w/load.php:160:944
	checkCssHandles https://fr.wikiquote.org/w/load.php:161:678
	execute https://fr.wikiquote.org/w/load.php:162:384
	implement https://fr.wikiquote.org/w/load.php:168:670
	<anonyme> https://fr.wikiquote.org/w/load.php:63:736

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMay 10 2017, 7:03 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Framawiki updated the task description. (Show Details)May 10 2017, 7:06 AM

For future reference, please attach &debug=true to the URL, like: https://fr.wikiquote.org/w/index.php?title=Discussion_utilisateur:Lykos&safemode=1&debug=true

This will show in the console that the problem which breaks Flow is custom local code in line 135 of https://fr.wikiquote.org/wiki/MediaWiki:Common.js . That's what needs to get fixed by an admin on that wiki.

Aklapper renamed this task from Flow is broken on frwikiquote: Error: Module site has failed dependencies to Flow is broken on frwikiquote due to local JavaScript in MediaWiki:Common.js.May 10 2017, 8:07 AM
Catrope closed this task as Resolved.EditedMay 10 2017, 5:50 PM
Catrope claimed this task.
Catrope added a subscriber: Catrope.

Note: this didn't fail with &safemode=1 for me, only without.

This change should fix it. That said, the surrounding code for interproject navigation (// Initialisation de la navigation interprojets (code adapté de de:wikt:Mediawiki:monobook.js)) doesn't seem to work, and probably has not worked in years.