Page MenuHomePhabricator

Revision create events are made for all history of a page when it is undeleted
Closed, ResolvedPublic

Description

T there's a revision-create event emitted for every single revision in the page history when the page is undeleted. When the page is deleted and restored, revision-create events are sent for all the historic revisions of the page

It's a big problem because it might make change-prop re-renader content a lot, however right now all of the extra events are being deduplicated.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 25 2017, 10:32 PM
Pchelolo updated the task description. (Show Details)May 25 2017, 10:37 PM
Pchelolo updated the task description. (Show Details)May 25 2017, 11:55 PM

Not reproducible in beta.
However, in beta cluster when the page is deleted and restored, revision-create events are sent for all the historic revisions of the page

This bit is confusing. Is it reproducible in beta or not?

This bit is confusing. Is it reproducible in beta or not?

Oh, sorry. So the original bug when the page is renamed and all the historic revisions are inserted again is not happening in the beta cluster.

However, I've discovered another unexpected behavior with page restoration. That one is not a bug, apparently it's expected behavior we just were not aware of. That one is reproducible. I should probably split this ticket in 2

GWicke triaged this task as Normal priority.Aug 8 2017, 5:53 PM
Pchelolo renamed this task from Revision create events are made for all history or a page when it is moved to Revision create events are made for all history or a page when it is undeleted.Feb 27 2018, 2:32 PM
Pchelolo updated the task description. (Show Details)
mobrovac renamed this task from Revision create events are made for all history or a page when it is undeleted to Revision create events are made for all history of a page when it is undeleted.Aug 28 2018, 1:57 PM

Change 458906 had a related patch set uploaded (by Ppchelko; owner: Ppchelko):
[mediawiki/extensions/EventBus@master] Use PageContentSaveComplete hook for revision-create.

https://gerrit.wikimedia.org/r/458906

Change 458906 merged by jenkins-bot:
[mediawiki/extensions/EventBus@master] Use PageContentSaveComplete hook for revision-create.

https://gerrit.wikimedia.org/r/458906

Pchelolo closed this task as Resolved.Sep 18 2018, 11:07 PM
Pchelolo edited projects, added Services (done); removed Patch-For-Review, Services (doing).

Deployed and tested on beta cluster, works like a charm now. Resolving.

THANKS PETRRRRR!