Page MenuHomePhabricator

[betalabs-regression] Enhanced RC displays misaligned timestamps in a smaller font
Closed, ResolvedPublic

Description

On betalabs RC page with enabled 'Enhanced recent changes' option will display

  • the timestamp for grouped edits misaligned
  • a smaller font for the timestamp and the legend letters

For comparison - testwiki (the same scale):

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 7 2017, 6:55 PM
Catrope closed this task as Invalid.Jul 7 2017, 7:08 PM
Catrope added a subscriber: Catrope.

The way it looks on beta is what it's "supposed" to look like, (the smaller font size appears to be because of font-family: monospace), the way it looks on testwiki is caused by the WatchlistGreenIndicators gadget. Disabling the gadget (https://test.wikipedia.org/w/index.php?title=Special:RecentChanges&enhanced=1&safemode=1) causes testwiki to look the same as beta.

Catrope reopened this task as Open.Jul 7 2017, 7:16 PM

That said, I think we should put this fix in core. There's this strange behavior in CSS That I don't understand (both Chrome and Firefox behave the same, so probably not a browser bug) where font-family: monospace causes the font size to be smaller, but font-size: monospace, monospace doesn't for some reason.

Current state (Chrome):

Current state (Firefox):

With patch (Chrome):

With patch (Firefox):

Change 363872 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] Fix font size / alignment of timestamps in enhanced recent changes

https://gerrit.wikimedia.org/r/363872

Change 363872 merged by jenkins-bot:
[mediawiki/core@master] Fix font size / alignment of timestamps in enhanced recent changes

https://gerrit.wikimedia.org/r/363872

The fix is checked in betalabs - looks good:

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Jul 11 2017, 11:52 PM
jmatazzoni claimed this task.