Page MenuHomePhabricator

Rename Project and Project_talk namespaces on Latvian Wiktionary
Closed, ResolvedPublic

Description

Please rename the following namespaces on the Latvian Wiktionary:

  • Project / Wiktionary → Vikivārdnīca
  • Project_talk / Wiktionary_talk → Vikivārdnīcas diskusija

Then run namespaceDupes.php on the wiki to move relevant existing pages into project space.

If it needs mentioning, "Wiktionary:" and "Wiktionary_talk:" should be kept as aliases after the renaming. (I believe this is the default behavior anyway?)

Brief explanation:

The Project and Project_talk namespaces (namespaces 4 and 5) on the Latvian Wiktionary were never localized. The canonical names "Wiktionary" and "Wiktionary_talk" were found to be unacceptable by the local community, so they created pages in the main namespace having the prefix "Vikivārdnīca:" (the local name for "Wiktionary:") and redirected titles in the "Wiktionary" namespace to these pages. This needs to be fixed by renaming the namespaces and running the script, as described above.

(BTW, there is little activity on the wiki nowadays, and the sole local admin hasn't edited any Wikimedia wiki since August 2015, so no help will be forthcoming on those fronts. I plan to request steward help with any post-renaming issues I cannot deal with as a regular user on that wiki.)

Background:

Details

Related Gerrit Patches:

Event Timeline

Dcljr created this task.Jul 9 2017, 3:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2017, 3:04 AM
Dcljr added a comment.Jul 9 2017, 3:23 AM

Oops: Note that the "Project_talk" namespace is currently called "Wiktionary diskusija", not "Wiktionary_talk".

MarcoAurelio triaged this task as Low priority.
MarcoAurelio moved this task from Backlog to Config - to process on the Wikimedia-Site-requests board.

The English ones do not need to be added as Project/Project talk; Wiktionary/Wiktionary talk will keep working even after we customize them locally.

Needs running namespaceDupes.php after rename so everything is sorted out.

Change 364197 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[operations/mediawiki-config@master] Add wgMetaNamespace / wgMetaNamespaceTalk for lv.wiktionary

https://gerrit.wikimedia.org/r/364197

Change 364197 merged by jenkins-bot:
[operations/mediawiki-config@master] Add wgMetaNamespace / wgMetaNamespaceTalk for lv.wiktionary

https://gerrit.wikimedia.org/r/364197

Mentioned in SAL (#wikimedia-operations) [2017-07-10T18:47:01Z] <niharika29@tin> Synchronized wmf-config/InitialiseSettings.php: Add wgMetaNamespace / wgMetaNamespaceTalk for lv.wiktionary [mediawiki-config] - https://gerrit.wikimedia.org/r/364197 (T170065) (duration: 00m 20s)

Forced renames to resolve dupes:

id=6958 ns=0 dbk=Vikivārdnīca:Administratori -> Vikivārdnīca:(Renamed)Administratori (alternate)
id=6834 ns=0 dbk=Vikivārdnīca:Aktualitātes -> Vikivārdnīca:(Renamed)Aktualitātes (alternate)
id=8357 ns=0 dbk=Vikivārdnīca:Babel -> Vikivārdnīca:(Renamed)Babel (alternate)
id=2503 ns=0 dbk=Vikivārdnīca:Kopienas_portāls -> Vikivārdnīca:(Renamed)Kopienas_portāls (alternate)
id=1575 ns=0 dbk=Vikivārdnīca:Latviešu_vārda_sagatave -> Vikivārdnīca:(Renamed)Latviešu_vārda_sagatave (alternate)
id=6608 ns=0 dbk=Vikivārdnīca:Par -> Vikivārdnīca:(Renamed)Par (alternate)
id=2270 ns=0 dbk=Vikivārdnīca:Starptautiskā_fonētiskā_alfabēta_attēlojums_Unikodā -> Vikivārdnīca:(Renamed)Starptautiskā_fonētiskā_alfabēta_attēlojums_Unikodā (alternate)
id=9131 ns=0 dbk=Vikivārdnīca:Svadeša_saraksts -> Vikivārdnīca:(Renamed)Svadeša_saraksts (alternate)
id=2255 ns=0 dbk=Vikivārdnīca:Valodu_kodi -> Vikivārdnīca:(Renamed)Valodu_kodi (alternate)

@Niharika Thanks. Can you run it again now that I've fixed the above ones to see if there's anything left?

Dcljr added a comment.EditedJul 10 2017, 10:01 PM

Hmm… the following pages (that were "supposed to" be in the Project_talk namespace but were actually in Talk) seem to have disappeared:

All of these titles now return a "Bad title" error and local [[wikilinks]] to them (using normal text, not the URL-escaped versions seen above) are not even recognized as links, despite the fact that they are still listed at: https://lv.wiktionary.org/wiki/Special:PrefixIndex/Talk:Vikiv .

Edit: Note that there were 2 "Kopienas portāls" talk pages before the change (listed here in local wikilink format):

  • [[Diskusija:Vikivārdnīca:Kopienas portāls]]
  • [[Wiktionary diskusija:Kopienas portāls]]

One of them "survived" at:

One of them seems to be gone (inaccessible).

Wait a minute… These 2 titles redirect to the corresponding pages listed above, but as you can see by looking at the redirect pages themselves, the wikilinks are not being recognized (as I said before):

(Obviously, certain redirects need to be deleted or pointed to different pages now that the settings change has been made. That will be done eventually. I'm just interested in how this technical error has arisen, and what happened to the 4 pages listed in my previous comment.)

That the script gives no trace of its activity on wiki (logs, history, etc.) is a bit problematic to follow what it has really done.

Does this now require cleanupTitles.php maybe? (I don't actually know the difference.)

@Dcljr I think I got them all. I pulled a list at P5715 to get me the pages in the Talk Namespace which could be broken, and moved the ones with several namespaces in the title via API, then put them back into the correct place. Please let me know if there's anything missing.

MarcoAurelio closed this task as Resolved.Jul 11 2017, 9:49 AM
MarcoAurelio removed a project: Patch-For-Review.
MarcoAurelio moved this task from ready to cabinet on the User-MarcoAurelio board.

@Niharika Thanks. Can you run it again now that I've fixed the above ones to see if there's anything left?

Hi! So the script fixed everything but in order for the script to run successfully, I renamed the duplicates (by adding a (Renamed) prefix) which I listed above. Does that make sense?
So there's nothing left to fix. :)

Dcljr added a comment.Jul 11 2017, 6:36 PM

From what I've seen so far, the "technical" issues have now been fixed (everything else that may need changing can be done on-wiki).

I see now that the fact that a page title like https://lv.wiktionary.org/wiki/Diskusija:Vikiv%C4%81rdn%C4%ABca:Administratori fails is a feature of the software, not a bug: the corresponding English title, https://en.wiktionary.org/wiki/Talk:Wiktionary:Administrators , also returns "Bad title".

I'll have to keep this in mind if I ever need to do this kind of renaming on another wiki. It's probably better to preemptively move certain titles before the namespace renaming that will become "bad titles" afterwards. Other titles can be handled by the script.

I do wonder, however, if cleanupTitles.php handles such cases better. If so, perhaps some of its functionality could be merged into namespaceDupes.php?</musing>

https://en.wiktionary.org/wiki/Talk:Wiktionary:Administrators is indeed a bad title. cleanupTitles or namespaceDupes could get it solved.

Dcljr added a comment.Jul 11 2017, 7:36 PM

@MarcoAurelio Do you know how cleanupTitles and namespaceDupes differ with respect to their treatment of such pages (of the form <Talk>:<Project>:<Title>), if at all?

It is my impression, based on what I've seen in other bugs/tasks, that cleanupTitles would rename such titles for easy moving to final destinations, whereas namespaceDupes allowed them to remain inaccessible. Am I wrong?

@Niharika Sorry, but for future reference, could you please post the exact command you used when you ran namespaceDupes? (Becuase the script did not actually fix everything.)

(And BTW, I'm not saying that Talk:Wiktionary:Administrators actually exists on en.wiktionary, of course.)

@Dcljr

Here's the series of commands I used:

  1. mwscript namespaceDupes.php --wiki=lvwiktionary to do a dry run and see what will be fixed.
  2. mwscript namespaceDupes.php --wiki=lvwiktionary --fix to fix whatever can be automatically fixed by the script.
  3. mwscript namespaceDupes.php --wiki=lvwiktionary again to see what remains. At that point it told me that there were 9 that need a prefix to be resolved.
  4. Then I ran mwscript namespaceDupes.php --wiki=lvwiktionary --add-prefix='(Renamed)' to resolve those.

I unfortunately no longer have the log for the command runs though.

From just now:

niharika29@terbium:~$ mwscript namespaceDupes.php --wiki=lvwiktionary
0 pages to fix, 0 were resolvable.

0 links to fix, 0 were resolvable.

Looks good!