Page MenuHomePhabricator

User page displaying <mobile-frontend-joined-months> instread of actual time on mobile
Closed, ResolvedPublic1 Estimate Story Points

Description

Steps to recreate:

  1. On the mobile website, login
  2. Open your user page

Observed behavior:

  • Page displays <mobile-frontend-joined-months>

Expected behavior:

  • Page should display when user created account

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : wmf/1.30.0-wmf.9Ship hour last modified message
mediawiki/extensions/MobileFrontend : wmf/1.30.0-wmf.10Ship hour last modified message
mediawiki/extensions/MobileFrontend : masterShip hour last modified message

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 18 2017, 11:33 AM
ovasileva triaged this task as High priority.Jul 18 2017, 11:33 AM
ovasileva updated the task description. (Show Details)
Aklapper renamed this task from User page dispaying <mobile-frontend-joined-months> instread of actual time on mobile to User page displaying <mobile-frontend-joined-months> instread of actual time on mobile.Jul 18 2017, 12:00 PM
Aklapper added a project: MobileFrontend.
ovasileva moved this task from Upcoming to 2017-18 Q1 on the Readers-Web-Backlog board.

regression we should fix soon - moving this into the sprint

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptJul 18 2017, 2:26 PM
pmiazga claimed this task.Jul 18 2017, 3:24 PM

I'll pick it up and work on it now

Issue doesn't existin on latests master branch. I can reproduce it on wmf/1.30.0-wmf.9 branch. It's probably rEMFRdf35f71cd804 is missing on wmf.9

Good catch! I've scheduled https://gerrit.wikimedia.org/r/#/c/366007/ for evening SWAT. It got merged into wmf9 and then reverted.

Also seeing this here in beta cluster which is probably related but not fixed by the above:

ovasileva set the point value for this task to 1.Jul 18 2017, 5:11 PM

Change 366018 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Ship hour last modified message

https://gerrit.wikimedia.org/r/366018

Change 366019 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.9] Ship hour last modified message

https://gerrit.wikimedia.org/r/366019

Change 366020 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.10] Ship hour last modified message

https://gerrit.wikimedia.org/r/366020

Change 366018 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Ship hour last modified message

https://gerrit.wikimedia.org/r/366018

Change 366019 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.9] Ship hour last modified message

https://gerrit.wikimedia.org/r/366019

Change 366020 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.10] Ship hour last modified message

https://gerrit.wikimedia.org/r/366020

Jdlrobson reassigned this task from pmiazga to ovasileva.EditedJul 18 2017, 7:00 PM
Jdlrobson added a subscriber: pmiazga.

@ovasileva can you sign off? Should be fixed everywhere now.

I tried this a few times on production and I was not able to reproduce it.

ovasileva closed this task as Resolved.Jul 19 2017, 5:43 PM

all done!