Page MenuHomePhabricator

Reply to a task via email is broken: "No concrete, enabled subclass of PhabricatorMailReceiver can accept this mail"
Closed, ResolvedPublic

Description

Phabricator sends emails with header e.g.,
Reply-to: T172982+public+4de70ae75f93f570@phabricator.wikimedia.org

But when one replies to it, one gets an error email:

Error Processing Mail (Empty Mail)

Your email to Phabricator was not processed, because an error occurred while
trying to handle it:

Phabricator can not process this mail because no application knows how to
handle it. Check that the address you sent it to is correct.

(No concrete, enabled subclass of PhabricatorMailReceiver can accept this
mail.)

Therefore in the initial mail it should say "Don't Reply to this mail." and
remove the Reply-to:, if not planning to process the mail.

Event Timeline

Jidanni created this task.Aug 10 2017, 12:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 10 2017, 12:18 PM
Aklapper updated the task description. (Show Details)Aug 10 2017, 12:25 PM

This is probably because we migrated to a new server. Replying to email is supported.

Aklapper renamed this task from No concrete, enabled subclass of PhabricatorMailReceiver can accept this mail to Reply to a task via email is broken: "No concrete, enabled subclass of PhabricatorMailReceiver can accept this mail".Aug 10 2017, 12:55 PM
Aklapper added a project: Regression.
Aklapper updated the task description. (Show Details)

Indeed, might be a regression from moving from iridium to phab1001.

Kind of confirming though I got a different reply, trying to reply via email to the initial task description and quoting some parts:

Your email to Phabricator was not processed, because an error occurred while
trying to handle it:

Your message does not contain any body text or attachments, so Phabricator can
not do anything useful with it. Make sure comment text appears at the top of
your message: quoted replies, inline text, and signatures are discarded and
ignored.

https://phabricator.wikimedia.org/config/edit/metamta.mail-adapter/ seems to be set to PhabricatorMailImplementationPHPMailerAdapter.
(Likely unrelated, I also see two metamta related items listed under config.ignore-issues on https://phabricator.wikimedia.org/config/all/)

Very strange.

zhuyifei1999 added a subscriber: zhuyifei1999.EditedSep 6 2017, 9:27 PM

Replying via mail did work for me in T171392#3554170

testing 1.2.3

mmodell closed this task as Resolved.Sep 6 2017, 9:40 PM
mmodell claimed this task.

Hmm, it works for me as well T172983#3586677

Doesn't seem to work for me. Or does it take a while for phab to pick it up?

Replied with

Paladox <thomasmulhall410@yahoo.com>
To:
mmodell

6 Sep at 22:40

testing mail too.

mmodell email shows as noreply@phabricator.wikimedia.org.