Page MenuHomePhabricator

MagicWord {{REVISIONUSER}} is not displayed in Wikipage
Closed, ResolvedPublic

Description

The MagicWord {{REVISIONUSER}} is not displayed in wikitext and print version of an the article.
In preview all is fine.

How to reproduce
Add Test= {{REVISIONUSER}} to a (user) page and click preview. All is fine.
Add Test= {{REVISIONUSER}} to a (user) page and click save.

Expected result
Test=Sundance_Raphael

Received result
Test=

Things that I have done

  • clear cache
  • Strg + F5
  • Null edit with same user
  • Edit article with same user

With no change of the result.

See example:
https://de.wikipedia.org/wiki/Benutzerin:Sundance_Raphael

Effected MW Version
1.29, 1.30.0-wmf.15

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2017, 1:12 PM
SundanceRaphael updated the task description. (Show Details)
Samtar added a subscriber: Samtar.

@SundanceRaphael I tried purging the page and it now appears for me

same trouble with Test= {{REVISIONUSER}} for me, but using Test= {{subst:REVISIONUSER}} works totally fine.
https://de.wikipedia.org/wiki/Spezial:Beitr%C3%A4ge/Anoop_Rao

And if you try test= {{REVISIONUSER}} --> save --> purge (append ?action=purge to the end of the URL) - does it display then?

I can confirm that after purging the {{REVISIONUSER}} entry appears, but after add a new version the {{REVISIONUSER}} is empty again.

Hm, I've replicated that too

  1. Create page with test= {{REVISIONUSER}}
  2. Save
  3. Content shows test =
  4. Purge
  5. Content shows test = [username]
  6. Add a line break, and some words
  7. Content shows test = (line break) some words
  8. Purge
  9. Content shows test = [username] (line break) some words

I have a feeling this is "expected" behaviour, Help:Magic words states "Due to MediaWiki and browser caching, these variables frequently show when the page was cached"

@Samtar you refer to the Date and time section of magic words. If i remember right this functionality is very special.

@Anooprao the i can confirm that {{subst:REVISIONUSER}} but i need not a at the end something like [[user:{{REVISIONUSER}} |{{REVISIONUSER}}]]

The problem is that the string becomes empty after new revision is created. For me is the "expected" behavior is like {{REVISIONID}}, "acceptable" behavior is "Show the last revision user before purge"
The interesting fact is that in the preview all is right.

Anooprao removed a subscriber: Anooprao.Aug 27 2017, 9:13 AM
Tgr closed this task as Resolved.EditedAug 31 2018, 11:47 AM
Tgr claimed this task.
Tgr added a subscriber: Tgr.

Should be fixed by the recent revision rendering rewrite in https://gerrit.wikimedia.org/r/c/mediawiki/core/+/451025 (T194048)