Page MenuHomePhabricator

Enable AbuseFilter profiler for es.wikiquote
Closed, ResolvedPublic

Description

Announcement / discussion.

After being asked for help I noticed very badly written filters there. It'd be good to have this enabled in order to detect the most unneficient ones and fine-tune them.

Event Timeline

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptOct 9 2017, 11:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
MarcoAurelio triaged this task as Low priority.Oct 9 2017, 12:06 PM
MarcoAurelio moved this task from Backlog to Working on on the Wikimedia-Site-requests board.
MarcoAurelio moved this task from unsorted/backlog to working on on the User-MarcoAurelio board.

Hmm. So we've got $wgAbuseFilterProfile in abusefilter.php, and now in InitialiseSettings we have also a $wgAbuseFilterRuntimeProfile -- which are the differences between them? Ping @TBolliger. I've always used AbuseFilterProfile, not Runtime. Not sure which one to enable now.

Hmm. So we've got $wgAbuseFilterProfile in abusefilter.php, and now in InitialiseSettings we have also a $wgAbuseFilterRuntimeProfile -- which are the differences between them. Ping @TBolliger. I've always used AbuseFilterProfile, not Runtime. Not sure which one to enable now.

I'm not sure, it's probably a better question for @dmaza.

dmaza added a comment.Oct 12 2017, 9:16 PM

@MarcoAurelio you need $wgAbuseFilterProfile.

$wgAbuseFilterProfile enables a per filter average runtime and used conditions that get displayed on the filter's edit page. This was previously disabled on most wikis 'cause it was causing performance issues but it looks like it was resolved later on. Technically it should be fine now but we are about to confirm it through T177641 which will go out in a few hours.

$wgAbuseFilterRuntimeProfile measures the total runtime of all filters and sends the data to statsd, which we are later tracking on this Grafana Dashboard

Regarding why we are setting things on two different places, I was the one that added $wgAbusefilterRuntimeProfile to InitialiseSettings but we can move it abusefilter.php along with the other AbuseFilter flags on that file.

@dmaza Thanks. I was just wondering about the RuntimeProfile flag. For now I'll get the normal profiler as intended. Spanish Wikiquote is a small wiki with few activity so I don't expect performance issues.

Change 384265 had a related patch set (by MarcoAurelio) published:
[operations/mediawiki-config@master] Enable AbuseFilter profiler for es.wikiquote

https://gerrit.wikimedia.org/r/384265

Change 384265 merged by jenkins-bot:
[operations/mediawiki-config@master] AbuseFilter configuration changes for es.wikiquote

https://gerrit.wikimedia.org/r/384265

Mentioned in SAL (#wikimedia-operations) [2017-10-16T14:08:05Z] <hashar@tin> Synchronized wmf-config/abusefilter.php: (T177760) Enable AbuseFilter profiler | (T177761) Allow AbuseFilter to block & grant relevant permissions to permit administrators to manage the restricted option. (duration: 00m 47s)

MarcoAurelio closed this task as Resolved.Oct 16 2017, 2:12 PM