Page MenuHomePhabricator

Integrate login with SUL
Closed, DeclinedPublic

Description

I have been told on various occasions that I just "report it on phabricator" and "it's the same username and password that you have on Wikipedia". But it never works for me; I can't login. Apparently it only works if your username confirms to a set of criteria different to Wikipedia's so my user name (with a space in it) never worked. And there is no way to get any help when the login screen sends you wrong in circles with different error messages like "OAuth token already used, E009". I don't have any OAuth issue with the toolservers so why here?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 26 2017, 11:00 PM

At the very least, when you get the error message about the user name, tell the user that what they have to do is replace all the illegal characters with underscore to make it work (or at least that is what I was told and that worked for me).

What software are you trying to log into and having problems with? Are you referring to Phabricator itself?

Kerry_Raymond added a comment.EditedOct 27 2017, 8:34 AM

Yes. People are always telling me to do things in phabricator but I haven't been able to login to it. See this most [https://en.wikipedia.org/wiki/Wikipedia_talk:WikiLove#Strange_behaviour_by_WikiLove.3F recent example]. Everyone *says* it is automatic with my Wikipedia login and never listens to me when I say that it does not work for me because it works fine for them. But when you are sitting in front of the login screen and it takes you round in circles with different error messages at different times, there is NO help from that screen to troubleshoot it and no link to where you can ask for help. I have even been told to report the login problem on phabricator which is really useless advice when I can't login to it. Quiditty is the first person to take the trouble to find out why I can't login. So now I can, I'd like to report that there are lots of people like me who probably can't login and there is no way to get help to do so.

Aklapper changed the task status from Open to Stalled.EditedOct 27 2017, 10:39 AM
Aklapper added a project: Phabricator.

Yes. People are always telling me to do things in phabricator but I haven't been able to login to it.

As you are writing this on Phabricator and as commenting on Phabricator is not possible without logging in, I assume you have managed. :)
It is not "the same username" (and I have no idea why people state this). But you will not have to remember another password.

If the login screen sends you in circles, feel free to report a bug about it with good steps to reproduce - might be a duplicate of T146122 though?

when you get the error message about the user name, tell the user that what they have to do is replace all the illegal characters with underscore

Separate task with clear steps to reproduce welcome (e.g. the exact error message) though this sounds like something that should be fixed by the upstream maintainers of the Phabricator software, outside of Wikimedia. https://secure.phabricator.com/rP152ddf57092e3c73d9dcc60f57cdedb1625b679d looks related. But it looks like T179126 already covers this now.

there is NO help from that screen to troubleshoot it and no link to where you can ask for help.

https://phabricator.wikimedia.org/login/ says: "In case of doubt, check the Phabricator Help: Creating your account." So there is a link.

Aklapper closed this task as Declined.Feb 19 2018, 12:43 PM

Unfortunately closing this report as no further information has been provided. @Kerry_Raymond: After you have provided information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Kerry_Raymond reopened this task as Open.Feb 28 2018, 6:42 AM

Having finally found out how to get back here - the notification I received did not provide any link back here.

What further information did you want from me? I did not see a specific question. Rather I read your previous message as dismissive, because you insist on saying there was a link on a screen that there was not. It may have been on some other screen, but once I was locked into the error circle, it was definitely not there. It was highly frustrating and not the first time it happened to me as I had previously attempted to report other bugs and had the same problem. It works for you, I get it, but it didn't work for me.

Please take this seriously. If the problem with usernames with spaces is a known problem, why isn't the error explicit about what the problem is and what to do about it.

Thank you

Kerry

Could you provide a list, step by step, plus expected and actual outcome that allows others to reproduce the problem? My understanding is that this task includes two issues: Something about being sent in circles, something about restrictions on the user name and not getting informed about that. Thanks in advance.

the notification I received did not provide any link back here.

The email notifications I receive (though plain text, have not tried HTML) all have a section

TASK DETAIL
 https://phabricator.wikimedia.org/T179124

Is that not the case for you? If not, can you attach an example?

Aklapper closed this task as Declined.Mar 30 2018, 10:11 PM

At the very least, when you get the error message about the user name, tell the user that what they have to do is replace all the illegal characters with underscore to make it work (or at least that is what I was told and that worked for me).

  1. I am logged in on https://www.mediawiki.org
  2. I go to https://phabricator.wikimedia.org/
  3. I click "Log in"
  4. I click "Log In Or Register - MediaWiki"
  5. In the OAuth dialog, I click "Allow"
  6. I get to the "Create a New Account" page on https://phabricator.wikimedia.org/auth/register/
  7. As "Username", I enter "ᐄ→Д"
  8. As "Also Known As", I enter "ᐄ→Д"
  9. I enter an email address
  10. I click "Register Account"
  11. I get: "Usernames must contain only numbers, letters, period, underscore and hyphen, and can not end with a period. They must have no more than 64 characters."

If you have or had a different experience then we need a list of steps to reproduce so we can investigate.
Unfortunately again closing this report. Please set the status of this report back to "Open" via the Add Action...Change Status dropdown if you can provide steps which allow someone else to reproduce the problems that you experience. Thanks a lot!