Page MenuHomePhabricator

IP blocked in Bologna
Closed, InvalidPublic

Description

Hi all.
Saturday November 11th, the IP of Salaborsa library in Bologna was completely blocked for 24 hours on a WikiDonne event (even I had a 24 hours users creation flag ), so nobody could work. This because a new partecipant did 2 times the registration: one on Commons (username Maca.albornoz) and one on Wikipedia (Maca.albornoz1 using the same email). So, immediately the antivandalism filter blocked infinetely not only theese usernames, but also all the other who share the same IP. Are are talking about here and here.
I think is a great limit of the software to not distinguish between a vandal and an innocuous error, because prevents the newbies participation and stops events, creating a normal frustration feeling.

The informations about are here

. Block number #458727, IP 46.255.84.17, from 10:33 of Novembre 11th to 10:33 of November 12th.
Is that a way to solve this issue?

Thank you, Camelia

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 14 2017, 1:27 PM
Reedy added a subscriber: Reedy.Nov 14 2017, 2:01 PM

I think is a great limit of the software to not distinguish between a vandal and an innocuous error, because prevents the newbies participation and stops events, creating a normal frustration feeling.

In most cases, blocks are in most cases done by people, not by the software itself.

What issue are you wanting to be solved here? I'm struggling to see anything that's directly actionable. If you're wanting the IP unblocking, you need to request that on the local wiki directly.

Many of users that partecipate in this discussions include the fact that there are no logs, so is impossible to track the steps were done.

This was not an "antivandalism filter". The administrator Gac (https://it.wikipedia.org/wiki/Utente:Gac) has blocked the user and automatically also all IP addresses used by them (this is the default behavior, but you can disable this when blocking). You can see this block listed in the logs: https://it.wikipedia.org/wiki/Speciale:Registri/Gac (search for "Maca.albornoz"). I am not familiar with Italian Wikipedia and I don't speak the language, perhaps this block was according to their rules. I'm afraid we can't help you here on Phabricator, since this is not a software bug; you will have to contact Gac or other Italian Wikipedia administrators to resolve this.

Thank you ;-). Camelia

Is it ok if i make this bug public?

Absolutely yes for me.

Bawolff closed this task as Invalid.Nov 14 2017, 2:28 PM
Bawolff changed the visibility from "Custom Policy" to "Public (No Login Required)".

As other people said, this particular case is not a bug, since the block for the IP range was intended by the sysop.
Nevertheless, when the IP is blocked automatically if a blocked user tries to login, the IP has no blocks in its block log, making its block very difficult to spot and, eventually, undo if necessary (like in this case). This actually is something which can be improved in terms of software.