Page MenuHomePhabricator

Fatal error: Call to a member function exists() on a non-object in ProofreadPage/DatabaseIndexForPageLookup.php
Closed, InvalidPublic

Description

[{exception_id}] {exception_url} BadMethodCallException from line 78 of /srv/mediawiki/php-1.31.0-wmf.10/extensions/ProofreadPage/includes/page/DatabaseIndexForPageLookup.php: Call to a member function exists() on a non-object (boolean)

Actual code:

$image = $this->repoGroup->findFile( $imageTitle );
if ( $image->exists() .. ) {
  ..
}

Most likely a regression caused by rEPRP5f80293b30df: Introduces IndexForPageLookup (or a56ea07e0). (Both merged without review?).

Previously:

Details

Related Gerrit Patches:
mediawiki/extensions/ProofreadPage : masterDo not fail if no image is built from the Page: page name

Event Timeline

Krinkle created this task.Dec 2 2017, 1:20 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 2 2017, 1:20 AM

Change 394770 had a related patch set uploaded (by Tpt; owner: Tpt):
[mediawiki/extensions/ProofreadPage@master] Do not fail if no image is built from the Page: page name

https://gerrit.wikimedia.org/r/394770

Tpt added a comment.Dec 2 2017, 8:19 PM

Most likely a regression caused by rEPRP5f80293b30df: Introduces IndexForPageLookup (or a56ea07e0).

It's rEPRP57e8b49becad27d3ce3eb3f994c131c206efd62c that merges duplicated code, removing the implementation with the bug fixed but keeping the one with the bug.

Both merged without review?

If you have time to do code reviews for ProofreadPage it would be great :-). I am the only volunteer with merge right on this extension and there is no WMF staff willing to do it.

Change 394770 abandoned by Tpt:
Do not fail if no image is built from the Page: page name

Reason:
Done by change I978ed2f9f3005210f6713a7f3ecde1fe0501a5ff

https://gerrit.wikimedia.org/r/394770

Tpt closed this task as Invalid.Dec 3 2017, 9:29 PM

Duplicate of T181944

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:09 PM