Page MenuHomePhabricator

Cannot correctly select text in chromium
Closed, ResolvedPublic

Description

Trying to select blocks of text just... doesn't work properly. I can't select it in real time (visual lag), only random sections go to clipboard, and sometimes it just plain won't select at all.

This only happens in chromium (and derivatives) in timeless. Other browsers are fine. The skin also seems to make chromium weirdly slow in general for some reason; this may be related.

Details

Related Gerrit Patches:
mediawiki/skins/Timeless : REL1_31Remove nonfunctional jquery mobile stuff
mediawiki/skins/Timeless : masterRemove nonfunctional jquery mobile stuff

Event Timeline

Isarra created this task.Dec 19 2017, 4:35 AM

Er, this is on linux (mouse clipboard), Chromium 63.0.3239.84, and when running out of SWAP. Yes, SWAP can be slow, but not this slow, and not for this, as evidenced by other skins not being affected. Tested on meta.

Oh, also hardware acceleration is disabled, may or may not be related, but now we're getting into the general rabbit hole of chromium's utter instability.

This has nothing to do with SWAP. Probably caused by disabling hardware acceleration combined with some css chromium doesn't handle well?

Has nothing to do with hardware acceleration; still occurs with it enabled.

Isarra moved this task from Backlog to Bugs on the Timeless board.Jun 5 2018, 11:05 AM

I knew what this was, never wrote it down, and now don't know what it is.

...the underlying cause may have also changed. This is/was a chrome bug. It may now be a different chrome bug, as it was previously triggered by certain css rules, which may have... changed?

It is now also being triggered by the js modules as well.

Change 440246 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Timeless@master] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440246

General note that the above patch is actually resolving something totally different from the original problem that was causing this, but that may have been fixed upstream regardless. Or something.

Change 440604 had a related patch set uploaded (by Paladox; owner: Isarra):
[mediawiki/skins/Timeless@REL1_31] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440604

Change 440246 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440246

Change 440604 merged by jenkins-bot:
[mediawiki/skins/Timeless@REL1_31] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440604

I am not sure if this is resolved now? The patch fixes the issues I was having, but what you're describing actually sounds different.

I thiiink the other issue was resolved upstream, and somewhere at the same time the same effect that the patch fixes moves in to replace it?! I don't even know.

Isarra closed this task as Resolved.Jun 15 2018, 9:00 PM
Isarra claimed this task.

So... yeah. Let's go with fixed.

Isarra reopened this task as Open.Jul 8 2018, 12:05 AM

NOPE, STILL HAPPENING. Or again. Or something.

Initial plan of totally rejig layout is back on table? UGH.

Isarra closed this task as Resolved.Jul 21 2018, 11:59 AM

I'm going to be really, really optimistic for no reason.