Page MenuHomePhabricator

Unable to select text by mouse inside the all VE dialogs when using Timeless skin
Closed, ResolvedPublic

Description

I am not able to select text and drag over the content by mouse inside the Notice Template dialog.

To be precise, issue reproduced on the Chrome browser while I made the following edit.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 27 2018, 12:04 PM
Deskana changed the task status from Open to Stalled.Feb 27 2018, 7:40 PM
Deskana added a subscriber: Deskana.

I'm not entirely certain what you mean. Can you provide clearer steps to reproduce this problem? Screenshots would be nice, as well.

I was trying to edit "Text for notice" in the "Notice dialog" as shown in the screenshot below.

More specific, I was trying to get rid of a few words starting from "Join us." While trying to select the text and drag over it from left to right by mouse, the mouse pointer got stuck after I selected a few characters and I wasn't able to select any further.

matmarex added a subscriber: matmarex.EditedMar 14 2018, 9:08 PM

I can reproduce this, but only on the Timeless skin. In fact, mouse clicking and dragging to select text is broken in all of VE's dialogs on that skin – I also tried selecting text in the "Media settings" dialog (in the caption edit field) and "Page settings" dialog. All text (including static labels) stops being selected after dragging for a few pixels horizontally; dragging vertically works as normal. Shift+click to select also works normally.

Recording of me trying really hard to select an image caption: https://drive.google.com/file/d/1PngcNkK7tnS583MD_yVTSiJJIx-Ja3I9/view?usp=sharing [use the download button in top-right corner] (file is too big for Phabricator)

Not Easy, I have no idea how or why this could possibly happen, much less how to fix it ;)

matmarex renamed this task from Unable to select text by mouse inside the Notice template dialog to Unable to select text by mouse inside the all VE dialogs when using Timeless skin.Mar 14 2018, 9:09 PM
matmarex changed the task status from Stalled to Open.
matmarex added a project: Timeless.

(I am using Opera 52 [like Chrome 65] on Windows 10. Firefox doesn't seem to have this problem.)

Esanders triaged this task as Lowest priority.Mar 14 2018, 9:21 PM
Esanders added a subscriber: Esanders.

Changing priority as Timeless is an unsupported skin.

Isarra added a subscriber: Isarra.Mar 14 2018, 9:41 PM

Welcome to chrome.

Sounds like the same thing as T183215 (but possibly compounded further by VE/OOJS specific stuff) which appears to be caused by overflow: rules and the whole floaty layout for the columns. Was planning to fix it by getting rid of the whole float approach entirely and replacing it with flexbox, or something, but then I never got the funding to properly work on any of this, so it's all just sat there.

(I'd be more specific about what rules exactly are causing this combined with what, but sadly I apparently neglected to write it down when I investigated for T183215. On the plus side, if this is the same thing, the severity of this particular issue should make it easier to check?)

I can reproduce this, but only on the Timeless skin.

Yes, I am using Timeless too!

Isarra moved this task from Backlog to Bugs on the Timeless board.Jun 5 2018, 11:05 AM

Change 440246 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Timeless@master] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440246

Can someone check if this is still happening, with and without the above patch? May have been resolved upstream regardless.

@Isarra Huh, that patch actually fixes this. That is very confusing, but also, nice.

matmarex added a comment.EditedJun 15 2018, 8:38 PM

So, I guess this was caused by some bug in the implementation of "swipe" events in jQuery Mobile. That kind of explains it.

Change 440604 had a related patch set uploaded (by Paladox; owner: Isarra):
[mediawiki/skins/Timeless@REL1_31] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440604

Change 440246 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440246

Change 440604 merged by jenkins-bot:
[mediawiki/skins/Timeless@REL1_31] Remove nonfunctional jquery mobile stuff

https://gerrit.wikimedia.org/r/440604

matmarex closed this task as Resolved.Jun 15 2018, 8:58 PM
matmarex assigned this task to Isarra.
matmarex removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 15 2018, 8:58 PM