Page MenuHomePhabricator

[betalabs] Related changes result set is not updated when a new article title is entered.
Closed, ResolvedPublic

Description

  1. Click on Random article and then on Related changes.
  2. Related changes will display the article title in the text box and the result set will reflect changes (if any) accordingly.
  3. Type another article title - the page won't refresh - the result set will stay the same.

e.g. in step 3, clean all filters, select 50 changes in 30 days, and type - Mavetuna13 1 - the result set won't change. Refresh the page, you'll see the results.

Note: after step 3 - url will be:

https://en.wikipedia.beta.wmflabs.org/w/index.php?target=Mavetuna13+1&limit=50&days=30&title=Special:RecentChangesLinked&damaging=verylikelybad&urlversion=2

and GET request in the Console for the previous Random article:

GET https://en.wikipedia.beta.wmflabs.org/w/index.php?target=gghjfy8yff9999&limit=50&days=30&title=Special:RecentChangesLinked&damaging=verylikelybad&urlversion=2&action=render&showlinkedto=0&enhanced=0 404 ()

Note1: I checked the production (wmf.12) - the issue is not present there.
Note2: the issue first looked the same as T183437: [wmf.12] Related changes without new filters - article title becomes sticky in Page name text box - but the issue of not refreshing the result set does not exist in production.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 21 2017, 12:34 AM

Change 399643 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/core@master] RCFilters: Query using current (not default) sticky parameters values

https://gerrit.wikimedia.org/r/399643

Change 399643 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Query using current (not default) sticky parameters values

https://gerrit.wikimedia.org/r/399643

Etonkovidova updated the task description. (Show Details)Dec 23 2017, 2:04 AM

Checked the fix in betalabs.

Etonkovidova closed this task as Resolved.Dec 23 2017, 2:09 AM