Page MenuHomePhabricator

Translate English parser functions / magic words into central Kurdish (CKB) language
Closed, ResolvedPublic

Description

Please translate the these magic words:
#ifexist to ئەگەر_ھەبوو
and
#if to ئەگەر
Thanks.

Event Timeline

Epine created this task.Feb 14 2018, 3:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2018, 3:50 PM

Please see and follow https://mediawiki.org/wiki/How_to_report_a_bug - thanks!
Where to see that? How to see that? Why do the Kurdish translations not include a #?
What makes you think that ifexist or if are magic words? Seeing https://www.mediawiki.org/wiki/Manual:Magic_words I'd rather think it's a parser function?

Epine added a comment.EditedFeb 15 2018, 8:56 AM

@Aklapper I didn't repeat the #, they should both be #ئەگەر & #ئەگەر_ھەبوو. Meaning it actually does include the #. And I'm not sure what you exactly refer to it with, but whatever it is, let it be, maybe magic word wasn't the correct word I used here.

P.S. How would "report a bug" page help me?

Aklapper changed the task status from Open to Stalled.Feb 15 2018, 11:19 AM

What makes you think that #ifexist can be translated to another language?
Could you please provide a link that shows that this can be technically translated?

P.S. How would "report a bug" page help me?

By structuring your bug reports in a way that allows others to see the problem and understand it. For example by steps to reproduce the problem which you have not provided. :)

Epine added a comment.Feb 16 2018, 8:56 AM

@Aklapper it is done in the Arabic Wikipedia. The translate If to لو and ifequation and ifexist... etc... if they can I'm sure so can we.

Aklapper triaged this task as Lowest priority.Feb 16 2018, 1:10 PM
Aklapper added a project: ParserFunctions.

@Epine: Thanks, that was helpful. I think I now found the place in the ParserFunctions extension: https://phabricator.wikimedia.org/diffusion/EPFN/browse/master/ParserFunctions.i18n.magic.php;efe3918159089430557636a270aabf1af8053a5b$35
If you feel like providing a patch yourself to fix your request, please see and follow https://www.mediawiki.org/wiki/Gerrit/Tutorial - thanks!

Aklapper renamed this task from Translate English magic words to central Kurdish for the CKB project to Translate English parser functions / magic words into central Kurdish (CKB) language.Feb 16 2018, 1:11 PM
Aklapper changed the task status from Stalled to Open.
Epine added a comment.Feb 17 2018, 9:21 AM

@Aklapper I have no idea how to do it myself, but I can provide you with the translations:

expr = دەربڕین
If = ئەگەر
Ifexpr = ئەگەر_دەربڕین
iferror = ئەگەر_ھەڵە
switch = گۆڕینەوە
default = بنچینەیی
ifexist = ئەگەر_ھەبوو
time = کات

And that's pretty much everything. If you could finish the job, I'll be thankful.

Sorry, I won't finish the job as I do not have time for this. You either have to wait for a volunteer to make that change, or you follow https://www.mediawiki.org/wiki/Gerrit/Tutorial and make that change yourself.

Epine added a subscriber: Amire80.Feb 19 2018, 4:10 PM

@Amire80 could you please do this?

Epine raised the priority of this task from Lowest to Normal.Feb 19 2018, 4:11 PM
Aklapper lowered the priority of this task from Normal to Lowest.Feb 19 2018, 4:28 PM

@Epine: Please do not change priority if you don't plan to work on a task. Thanks for your understanding.

Hi,

I can do this technically, but just for verification: Was there any discussion about this among Kurdish speakers elsewhere? For example, on the Kurdish Wikipedia talk pages?

Thanks.

Epine added a comment.Feb 23 2018, 7:40 PM

@Amire80 is it done yet?

@Epine: No (see "Open" in the upper left corner for the task status). Please either be patient or provide a patch yourself if you think this is urgent for some reason.

Ghybu added a subscriber: Ghybu.EditedMar 6 2018, 1:08 PM

@Epine For me, translating these names is like translating C++, Lua or Python into Kurdish. It is more interesting for Soranî (ckb) users rather learn the names of these functions to be able to use them in other wikis. It will also allow them to begin to become familiar with the programming.

After perhaps mixing RTL and LTR scripts can cause display or read problems (?)

@Epine For me, translating these names is like translating C++, Lua or Python into Kurdish. It is more interesting for Soranî (ckb) users rather learn the names of these functions to be able to use them in other wikis.

When it's done, both English and Kurdish versions will be usable.

It will also allow them to begin to become familiar with the programming.

The point of Wikipedia is not to teach people programming, but to allow people to write articles as easy as possible.

After perhaps mixing RTL and LTR scripts can cause display or read problems (?)

In fact, RTL and LTR is the best reason for doing this. Inside RTL text, it's more convenient to use the RTL versions of the magic words. In LTR text you can use the English version.

It was done in Hebrew, and it's quite convenient.

For LTR languages it's less important.

To sum things up, the general idea of translation is valid. My question is more about the correctness of the suggested translations.

Epine added a comment.Mar 6 2018, 1:42 PM

@Amire80 I'm a native Kurdish speaker and a ckb administrator. These translations are 100% correct.

Epine changed the task status from Open to Stalled.Apr 7 2018, 2:21 PM

@Ghybu

For me, translating these names is like translating C++, Lua or Python into Kurdish.

We can limit such translation requests to RTL languages only, because FWIW, Hebrew users also wanna translate "<foo/bar>" tags (e.g. <ref>, <nowiki>, and even <h1/2/3/4/5/6>, <strong>, <bold>, <bdi>, <html>, <head>, <body>, <span>...) which generally defined by W3C

Don't exaggerate please :)

<ref> is not defined by W3C, it just looks like XML, and there is demand in the Hebrew Wikipedia to somehow resolve the problem of combining <ref> while editing in wiki syntax with numbers, URLs, etc., and in practice the solution is to use a template. This is OK for wiki syntax editors, but has many issues with Visual Editor. Having something more structured would be better. Translating it to Hebrew is one option; it's problematic in itself, but I'm not aware of better options.

A lot of changes are needed around <nowiki>, but not translating it.

And I'm not aware of anybody who suggested translating <h1/2/3/4/5/6>, <strong>, etc. They aren't even used in MediaWiki.

@Aklapper I have no idea how to do it myself, but I can provide you with the translations:
expr = دەربڕین
If = ئەگەر
Ifexpr = ئەگەر_دەربڕین
iferror = ئەگەر_ھەڵە
switch = گۆڕینەوە
default = بنچینەیی
ifexist = ئەگەر_ھەبوو
time = کات
And that's pretty much everything. If you could finish the job, I'll be thankful.

@Amire80 please finish the translations but without switch and default, don’t translate those please. Thanks.

Epine changed the task status from Stalled to Open.Jul 22 2018, 10:13 AM
Epine assigned this task to Amire80.
Epine added a subscriber: Calak.Jul 22 2018, 12:53 PM
Epine added a comment.Jul 29 2018, 3:19 PM

@Aklapper please raise the task’s priority level to normal.

@Epine: Did @Amire80 explicitly agree to become the task assignee? Please read T187333#3983865 again. The field reflects reality and does not cause it.
If you are interested in getting this fixed, you and anybody else is very welcome to contribute a code change for review. Thanks.

Epine added a comment.Jul 29 2018, 9:49 PM

@Aklapper I believe so since he was ready to change it and made a comment locally.

@Raymond and @siebrand can either of you please see if you can implement this? It’s been months since this request has been placed.

I can do it.

Change 484375 had a related patch set uploaded (by Amire80; owner: Amire80):
[mediawiki/extensions/ParserFunctions@master] Add translations for ckb

https://gerrit.wikimedia.org/r/484375

Change 484375 merged by jenkins-bot:
[mediawiki/extensions/ParserFunctions@master] Add translations for ckb

https://gerrit.wikimedia.org/r/484375

Epine closed this task as Resolved.Mar 15 2019, 8:15 PM