Page MenuHomePhabricator

Have Thumbor use a different Swift user when dealing with private containers
Closed, ResolvedPublic

Description

This should avoid potential thumbnail access leaks when a private wiki is created but not added to swift::proxy::private_container_list

Event Timeline

Gilles triaged this task as Low priority.Feb 20 2018, 7:05 PM
Gilles created this task.

Change 414629 had a related patch set uploaded (by Gilles; owner: Gilles):
[mediawiki/core@master] Separate additional swift users for public and private

https://gerrit.wikimedia.org/r/414629

Change 414630 had a related patch set uploaded (by Gilles; owner: Gilles):
[mediawiki/vagrant@master] Add new Thumbor config keys for private swift user

https://gerrit.wikimedia.org/r/414630

Change 414631 had a related patch set uploaded (by Gilles; owner: Gilles):
[operations/puppet@production] Add Thumbor private container user configuration keys

https://gerrit.wikimedia.org/r/414631

Gilles moved this task from Inbox to Doing on the Performance-Team board.Feb 26 2018, 9:13 PM

Change 414965 had a related patch set uploaded (by Gilles; owner: Gilles):
[operations/mediawiki-config@master] Set up separate Thumbor Swift user for private containers

https://gerrit.wikimedia.org/r/414965

Change 415006 had a related patch set uploaded (by Gilles; owner: Gilles):
[operations/debs/python-thumbor-wikimedia@master] Upgrade to 1.15

https://gerrit.wikimedia.org/r/415006

Change 414965 merged by jenkins-bot:
[operations/mediawiki-config@master] Set up separate Thumbor Swift user for private containers

https://gerrit.wikimedia.org/r/414965

Mentioned in SAL (#wikimedia-operations) [2018-02-27T15:00:02Z] <gilles@tin> Synchronized wmf-config/filebackend.php: Thumbor private wiki support deployment: [[gerrit:414965| (T187822)]] (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2018-02-27T15:02:19Z] <gilles@tin> Synchronized private/PrivateSettings.php.example: Thumbor private wiki support deployment: [[gerrit:414965| Set up separate Thumbor Swit user for private containers (T187822)]] (duration: 00m 55s)

Change 415006 merged by Filippo Giunchedi:
[operations/debs/python-thumbor-wikimedia@master] Upgrade to 1.15

https://gerrit.wikimedia.org/r/415006

Mentioned in SAL (#wikimedia-operations) [2018-02-28T10:59:53Z] <godog> upload python-thumbor-wikimedia 1.15 - T187822 T187350

Change 415263 had a related patch set uploaded (by Filippo Giunchedi; owner: Filippo Giunchedi):
[operations/puppet@production] hieradata: add private wikis thumbor swift user

https://gerrit.wikimedia.org/r/415263

Change 414629 merged by jenkins-bot:
[mediawiki/core@master] Separate additional swift users for public and private

https://gerrit.wikimedia.org/r/414629

Change 415263 merged by Filippo Giunchedi:
[operations/puppet@production] hieradata: add private wikis thumbor swift user

https://gerrit.wikimedia.org/r/415263

Change 416403 had a related patch set uploaded (by Filippo Giunchedi; owner: Filippo Giunchedi):
[operations/puppet@production] hieradata: rename thumbor-private user

https://gerrit.wikimedia.org/r/416403

Change 416403 merged by Filippo Giunchedi:
[operations/puppet@production] hieradata: rename thumbor-private user

https://gerrit.wikimedia.org/r/416403

Mentioned in SAL (#wikimedia-operations) [2018-03-12T15:28:22Z] <gilles@tin> Synchronized private/PrivateSettings.php.example: Thumbor private wiki support deployment: [[gerrit:414631| Set up separate Thumbor Swift user for private containers (T187822)]] (duration: 00m 54s)

Gilles moved this task from Backlog to Doing on the Thumbor board.Mar 14 2018, 10:23 AM

Change 414631 merged by Filippo Giunchedi:
[operations/puppet@production] Add Thumbor private container user configuration keys

https://gerrit.wikimedia.org/r/414631

Gilles closed this task as Resolved.Mar 15 2018, 8:53 AM

Change 414630 abandoned by Gilles:
Add new Thumbor config keys for private swift user

Reason:
Seems like it was a dupe of some kind, or I subsequently included those changes in another commit

https://gerrit.wikimedia.org/r/414630