Page MenuHomePhabricator

Constraint check after save shows no results after adding new statement
Closed, ResolvedPublic

Description

It seems that constraint checks after adding a new statement only work when the “add value” feature was used to add another value to a statement that already existed when the page was loaded, but not on other new statements. The wbcheckconstraints API request is sent and receives a response, but nothing shows up on the page.

Probably some difference in the server-side- and client-side-generated HTML, I suspect.

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterCorrectly set element ID in statement group view

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 9 2018, 10:24 AM

I suspect this is a regression in Wikibase – the reason that the gadget doesn’t attach the icon is that the surrounding statement group no longer has a proper ID:

<div class="listview-item wikibase-statementgroupview" id="">
  ...
</div>

If this were an intentional change, surely we would have removed the id attribute completely instead of setting it to the empty string? (An empty ID is not valid according to the W3C validator.)

I observed the same empty ID on the Wikibase Registry, which is running using @Addshore’s Docker setup in MediaWiki 1.30.0, so it seems this bug has been present for some time already…

Or is it possible that this simply never worked? jquery.wikibase.statementgroupview.js hasn’t seen much activity, and at a glance it looks like there simply might not be any code to update the ID.

Change 432114 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] Correctly set element ID in statement group view

https://gerrit.wikimedia.org/r/432114

Change 432114 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Correctly set element ID in statement group view

https://gerrit.wikimedia.org/r/432114

Lea_Lacroix_WMDE closed this task as Resolved.May 28 2018, 9:48 AM
Lea_Lacroix_WMDE claimed this task.
Lea_Lacroix_WMDE added a subscriber: Lea_Lacroix_WMDE.

Tested, it works!

Vvjjkkii renamed this task from Constraint check after save shows no results after adding new statement to kbdaaaaaaa.Jul 1 2018, 1:11 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Lea_Lacroix_WMDE as the assignee of this task.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from kbdaaaaaaa to Constraint check after save shows no results after adding new statement.Jul 1 2018, 3:03 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Lea_Lacroix_WMDE.
CommunityTechBot raised the priority of this task from High to Needs Triage.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.