Page MenuHomePhabricator

Poor usability on Global User Preferences with two rows of checkboxes
Closed, DuplicatePublic

Description

Why are there 3 states with two checkboxes?

Event Timeline

Reedy created this task.Jun 1 2018, 11:56 AM
Restricted Application added a project: Community-Tech. · View Herald TranscriptJun 1 2018, 11:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Reedy renamed this task from Poor usability on Global User Preferences for Beta Features to Poor usability on Global User Preferences with two rows of checkboxes.Jun 1 2018, 12:00 PM
Reedy updated the task description. (Show Details)
Reedy added a comment.Jun 1 2018, 2:01 PM

Related to T188424 too I guess

TBolliger added a subscriber: TBolliger.EditedJun 1 2018, 3:38 PM

One problem here is that the beta tab uses OOUI elements and Global Preferences does not. CommTech punted on making Global Preferences OOUI compliant until regular preferences are successfully converted to OOUI: T186842

And from a usability point of view, the two rows of preferences is less than ideal. But 'fixing' the design of preferences is outside of the scope of this project. We're favoring function over form on this project as the target audience is power users and this is a set-it-and-forget it feature.

And yes, this is probably a duplicate of T188424: Improve the UI of Global Preferences (aka "fix two vertical rows of checkboxes")

Reedy added a comment.Jun 1 2018, 3:43 PM

And from a usability point of view, the two rows of preferences is less than ideal. But 'fixing' the design of preferences is outside of the scope of this project. We're favoring function over form on this project as the target audience is power users and this is a set-it-and-forget it feature.

Developers make poor user interfaces, and are often happy to use them. Doesn't make it right, or sensible for other users (whether power or not).

It's not about fixing the design of preferences itself, though, that could be part of it. You're reusing the Preferences form from core... then adding extra complexity to it.

Why does it need an extra check box?

Reedy added a comment.Jun 1 2018, 3:45 PM

One problem here is that the beta tab uses OOUI elements and Global Preferences does not.

It is. But all of the forms have extra checkboxes too. As the beta part was mostly irrelevant, I had already updated the ticket to reflect this

Merging as a duplicate of T188424: Improve the UI of Global Preferences (aka "fix two vertical rows of checkboxes") because both tickets are posing the same problem: the current UI of two rows of checkboxes use a substandard UI.

Regardless, this work is outside the scope of the Community Tech team for 2018.

Vvjjkkii renamed this task from Poor usability on Global User Preferences with two rows of checkboxes to iubaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
A2093064 renamed this task from iubaaaaaaa to Poor usability on Global User Preferences with two rows of checkboxes.Jul 1 2018, 1:24 AM
A2093064 raised the priority of this task from High to Needs Triage.
A2093064 updated the task description. (Show Details)
A2093064 added a subscriber: Aklapper.
CommunityTechBot closed this task as a duplicate.Jul 5 2018, 6:56 PM