Page MenuHomePhabricator

Inline script for 'wgBackendResponseTime' missing in prod
Closed, ResolvedPublic

Description

Noticed it just now, on all prod page views (tried various different kinds of wikis) the script is not there at the end of the body HTML.

https://test.wikipedia.org/w/index.php?title=Sandbox&action=history

However, it's fine in beta and locally. A quick try of echo wfReportTime() from mwscript eval.php on the same app servers that gave me the page without it, shows that at least that method is working fine, so it must be a hook or some later code messing it up.


Regression introduced by b2982e5d9c47708bb0 / 36459482b098f3b (1.32.0-wmf.6)

Details

Related Gerrit Patches:
mediawiki/core : wmf/1.32.0-wmf.7Update wikimedia/wrappedstring to 3.0.1
mediawiki/vendor : wmf/1.32.0-wmf.7Update wikimedia/wrappedstring to 3.0.1
mediawiki/core : masterUpdate wikimedia/wrappedstring to 3.0.1
mediawiki/vendor : masterUpdate wikimedia/wrappedstring to 3.0.1
WrappedString : masterFix handling of empty lists

Event Timeline

Krinkle created this task.Jun 5 2018, 6:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 5 2018, 6:41 PM
# SkinTemplate::prepareQuickTemplate / reporttime / str
string(136) "<script>(window.RLQ=window.RLQ||[]).push(function(){mw.config.set({"wgBackendResponseTime":188,"wgHostname":"mwdebug1001"});});</script>"
# BaseTemplate::printTrail / trail / var
object(Wikimedia\WrappedStringList)#2540 (2) {
  ["sep":protected]=>
  string(1) "
"
  ["wraps":protected]=>
  array(3) {
    [0]=>
    string(0) ""
    [1]=>
    object(Wikimedia\WrappedStringList)#1845 (2) {
      ["sep":protected]=>
      string(1) "
"
      ["wraps":protected]=>
      array(1) {
        [0]=>
        object(Wikimedia\WrappedStringList)#1844 (2) {
          ["sep":protected]=>
          string(1) "
"
          ["wraps":protected]=>
          array(0) {
          }
        }
      }
    }
    [2]=>
    object(Wikimedia\WrappedString)#2308 (3) {
      ["value":protected]=>
      string(136) "<script>(window.RLQ=window.RLQ||[]).push(function(){mw.config.set({"wgBackendResponseTime":188,"wgHostname":"mwdebug1001"});});</script>"
      ["prefix":protected]=>
      string(52) "<script>(window.RLQ=window.RLQ||[]).push(function(){"
      ["suffix":protected]=>
      string(12) "});</script>"
    }
  }
}
# BaseTemplate::printTrail / trail / str
string(0) ""

Looks like a regression in WrappedString.

Change 437531 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[WrappedString@master] Reproduce bug T196496

https://gerrit.wikimedia.org/r/437531

Krinkle triaged this task as High priority.Jun 5 2018, 7:05 PM

This recent regression is blocking analysis for T176916.

Change 437531 merged by jenkins-bot:
[WrappedString@master] Fix handling of empty lists

https://gerrit.wikimedia.org/r/437531

Change 437633 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@master] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437633

Change 437635 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/vendor@master] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437635

Change 437635 merged by jenkins-bot:
[mediawiki/vendor@master] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437635

Change 437633 merged by jenkins-bot:
[mediawiki/core@master] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437633

Change 437652 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/core@wmf/1.32.0-wmf.7] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437652

Change 437653 had a related patch set uploaded (by Krinkle; owner: Krinkle):
[mediawiki/vendor@wmf/1.32.0-wmf.7] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437653

Change 437653 merged by jenkins-bot:
[mediawiki/vendor@wmf/1.32.0-wmf.7] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437653

Change 437652 merged by jenkins-bot:
[mediawiki/core@wmf/1.32.0-wmf.7] Update wikimedia/wrappedstring to 3.0.1

https://gerrit.wikimedia.org/r/437652

Mentioned in SAL (#wikimedia-operations) [2018-06-06T01:06:28Z] <krinkle@deploy1001> Synchronized php-1.32.0-wmf.7/vendor/: I5a5d7de4702c23f0 / T196496 (duration: 01m 35s)

Krinkle updated the task description. (Show Details)Jun 6 2018, 1:07 AM

Mentioned in SAL (#wikimedia-operations) [2018-06-06T01:07:43Z] <krinkle@deploy1001> Synchronized php-1.32.0-wmf.7/composer.json: I13dbdba2b9d / T196496 (duration: 00m 57s)

Krinkle closed this task as Resolved.Jun 6 2018, 1:35 AM
Krinkle removed a project: Patch-For-Review.
Vvjjkkii renamed this task from Inline script for 'wgBackendResponseTime' missing in prod to 3kbaaaaaaa.Jul 1 2018, 1:05 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Krinkle as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
thcipriani renamed this task from 3kbaaaaaaa to Inline script for 'wgBackendResponseTime' missing in prod.Jul 1 2018, 7:45 PM
thcipriani closed this task as Resolved.
thcipriani assigned this task to Krinkle.
thcipriani updated the task description. (Show Details)