Page MenuHomePhabricator

Deleting a caption field that has text that exceeds the limit does not re-enable the "publish" button
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Enter a caption with a short text string
  2. Enter another caption with a long text string that exceeds the character/byte limit. Notice how the "Publish" button becomes disabled.
  3. Delete the caption in step 2.
  4. Publish button does not become enabled again.

Expected/desired behavior: when all offending text boxes are no longer present, re-enable the publish button.

See GIF below for an example of the bug.

Event Timeline

Restricted Application added a project: Multimedia. · View Herald TranscriptNov 13 2018, 1:29 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ramsey-WMF triaged this task as Low priority.Nov 13 2018, 1:30 AM

Assigning low priority since there are ways for the user to intuitively work around the problem. Still, it would be great to have this fixed :)

Ramsey-WMF moved this task from Untriaged to Triaged on the Multimedia board.Nov 13 2018, 1:30 AM
Jdforrester-WMF renamed this task from Beta Commons: Deleting a caption field that has text that exceeds the limit does not re-enable the "publish" button to Deleting a caption field that has text that exceeds the limit does not re-enable the "publish" button.Jan 11 2019, 10:27 PM

Change 483877 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/WikibaseMediaInfo@master] CaptionPanel: Factor out Publish enable/disable, call when row deleted

https://gerrit.wikimedia.org/r/483877

Change 483877 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] CaptionPanel: Factor out Publish enable/disable, call when row deleted

https://gerrit.wikimedia.org/r/483877

Ramsey-WMF closed this task as Resolved.Jan 17 2019, 8:16 PM

Confirmed to be working on production.