Page MenuHomePhabricator

“⧼advancedsearch-field-inlanguage⧽” in AdvancedSearch form (message broken?)
Closed, ResolvedPublic2 Story Points

Description

On this search page, the inlanguage parameter is displayed to me as “⧼advancedsearch-field-inlanguage⧽” instead of “Pages in this language”.

The message MediaWiki:advancedsearch-field-inlanguage exists, so I’m not sure why this is happening. But if this form is assembled client-side, then perhaps there’s some ResourceLoader setup missing to make sure that message is also available in JavaScript?

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptNov 25 2018, 11:12 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Lea_WMDE added a subscriber: Lea_WMDE.

Can you please look into this? :)

Change 475982 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/AdvancedSearch@master] Add missing i18n to load for the lazy load interface

https://gerrit.wikimedia.org/r/475982

WMDE-Fisch set the point value for this task to 2.
WMDE-Fisch moved this task from Sprint Backlog to Review on the WMDE-QWERTY-Sprint-2018-11-20 board.

Change 475983 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/AdvancedSearch@master] Add advancedsearch-field-inlanguage to ext.advancedSearch.elements

https://gerrit.wikimedia.org/r/475983

Change 475982 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@master] Add missing i18n to load for the lazy load interface

https://gerrit.wikimedia.org/r/475982

Change 475983 abandoned by Lucas Werkmeister (WMDE):
Add advancedsearch-field-inlanguage to ext.advancedSearch.elements

Reason:
see I8dae13d205

https://gerrit.wikimedia.org/r/475983

Lea_WMDE closed this task as Resolved.Dec 3 2018, 9:00 AM
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2018-11-20 board.