Page MenuHomePhabricator

Tracking down gary@ and redirecting it to tsops@
Closed, ResolvedPublic

Description

Hey Tech Ops,

I'm trying to track down where gary@ points to and redirect it to trustandsafety@. I can't find a record of it in our LDAP and was wondering if it's an old Ops-level alias. Can you please take a look?

Thanks,
Brendan

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 26 2018, 10:43 PM
Krenair added a subscriber: Krenair.
Dzahn added a subscriber: Dzahn.Nov 26 2018, 10:56 PM

@bcampbell gary@ is indeed in the config on our side, it is an alias for box6699@, along with pat@.

box6699@ itself is an alias for: mdennis@, archive01@.

mdennis@ is a Google account on your side and archive01@ is an OTRS queue.

Let's clean it up all at once and also do something with pat@ what about box6699@ in general. and what about the OTRS queue "archive01". Added Legal.

282 ## Legal ##
283 legal-en:       legal
284 pat:            box6699
285 gary:           box6699
286 box6699:        mdennis, archive01
287 gc:             legal
288 legalquestions: legal, liaison
Dzahn changed the visibility from "Public (No Login Required)" to "Subscribers".Nov 26 2018, 11:00 PM
Dzahn changed the edit policy from "All Users" to "Subscribers".
Dzahn changed the visibility from "Subscribers" to "Public (No Login Required)".
Dzahn changed the edit policy from "Subscribers" to "All Users".
Dzahn added a subscriber: RStallman-legalteam.
Krenair added a comment.EditedNov 26 2018, 11:03 PM

Interesting, I've never noticed that queue before. Earliest record I've found is an OTRS admin changing it around October 2010.

@bcampbell btw, if you are wondering about those aliases again, we have an automatic cron job that sends the entire alias file to officeit@wikimedia.org once per day at midnight, unless that broke or gets filtered somewhere

@bcampbell I am trying to move this forward, were you able to follow up with legal (or they can tell us) to know what is desired final state, and we will alter as needed the T210464#4776173 config, found at our private puppet repo.

@jcrespo It looks like @Dzahn added @RStallman-legalteam to the thread for Legal's input, but I can follow-up with legal via email if necessary. This request stemmed from an OIT techsupport ticket from @Jalexander requesting that gary@ be changed to an alias for trustandsafety@.

jijiki triaged this task as Normal priority.Dec 4 2018, 10:15 PM
jijiki added a subscriber: jijiki.

@bcampbell it would be great if @RStallman-legalteam or someone from legal could let us now how to handle this properly.

@jijiki I'll email Legal today and follow up with an answer on this thread. Thanks for your help.

Sorry I haven't responded! Not sure how to handle this one, but I will ask among the legal team and get back to the thread.

Let's clean it up all at once and also do something with pat@ what about box6699@ in general. and what about the OTRS queue "archive01". Added Legal.

282 ## Legal ##
283 legal-en:       legal
284 pat:            box6699
285 gary:           box6699
286 box6699:        mdennis, archive01
287 gc:             legal
288 legalquestions: legal, liaison

I think it would be good for us to convert these into google aliases so that OIT can deal with them a bit easier in the future if necessary and clean out the historical alises. Talking to legal and the team I think we probably want to do that as:

legal-en. gc, legalquestions can all go to legal@ (only)
pat, gary, box6699 can redirect to trustandsafety@ (only)

We can set these aliases up on our end. Just let me know when to do so. I imagine you'll remove the aliases from your end and we'll add said aliases to our end?

Thanks @bcampbell ! Actually it's usually the other way around, you can create these any time and let us know when done and then we delete our side and it should be a smooth transition.

@Dzahn makes sense, thanks. I'll let you know.

@Jalexander it looks like you requested OIT to rename trustandsafety@ to tsops@ on 8/1/18. I can confirm that trustandsafety@ no longer exists as a Google Group on our end as it is now named tsops@. Should I add trustandsafety@ as an alias for tsops@? Should I add pat, gary, box6699 for aliases to tsops@? Thanks.

Hey folks. Not sure what to do for this task now that James is gone. Should I make the changes I suggested?

Dzahn added a subscriber: jrbs.Feb 11 2019, 10:05 PM

Pinging @jrbs to help answering that question, per IRC.

jrbs added a comment.Feb 13 2019, 10:21 PM

@Jalexander it looks like you requested OIT to rename trustandsafety@ to tsops@ on 8/1/18. I can confirm that trustandsafety@ no longer exists as a Google Group on our end as it is now named tsops@. Should I add trustandsafety@ as an alias for tsops@? Should I add pat, gary, box6699 for aliases to tsops@? Thanks.

We already use trustandsafety@ as a team mailing list so I'm not sure what the status is there. Perhaps it's already an alias for tsops@? I'm circling back with my team to work out what is intended there.

No matter what the "main" Google Group is, I think your plan to forward them all to the team Group works for us, whatever that group is now called.

@jrbs Okay, so I think I figured this out...

trustandsafety is currently an alias for the Google Group susa@wikimedia.org. tsops@ is a Google Group that was formerly the Google Group trustandsafety@ and was renamed in August 2018 by OIT at the request of James. tsops@ has no aliases.

Given this, should I add the aliases (pat, gary, box6699) to tsops@wikimedia.org?

jrbs added a comment.Feb 19 2019, 11:16 PM

Whew. Thanks for unravelling that! I think that is a remnant of a move we were intending to make internally (i.e. having one email for Ops and another for Policy, both of which are subteams under Trust and Safety).

Rather than going down that rabbit hole again, I think redirecting to tsops@ is a good idea for now. I'll touch base with my team for the best solution to the larger problem of having a whole bunch of Google Groups.

jrbs renamed this task from Tracking down gary@ and redirecting it to trustandsafety@ to Tracking down gary@ and redirecting it to tsops@.Feb 19 2019, 11:16 PM

@Dzahn I just added pat@, gary@, and box6699@ as aliases to Google Group tsops@wikimedia.org. You should be able to delete on your side now.

Dzahn claimed this task.Mar 4 2019, 9:34 AM
Dzahn added a comment.Mar 4 2019, 10:40 AM

@bcampbell Cool, thank you! Removed pat@, gary@ and box6699@.

Now the only legal-related aliases we maintain are:

283 legal-en:       legal
284 gc:             legal
285 legalquestions: legal, liaison

Optionally you could also add these to the legal@ in Google and we could remove that as well.

Dzahn closed this task as Resolved.Mar 4 2019, 10:40 AM