Page MenuHomePhabricator

ensure_content_type version checking fails if actual version patch number >=10
Closed, ResolvedPublic

Description

Today we encountered an incident where after an MCS deploy, which
changed the summary version from 1.3.9. to 1.3.10, caused RB to rerender
the summary for every page.[1]

The problem is that the comparison previously used failed when the patch
version number was 10 or greater and the expected patch version number
is < 10.

Event Timeline

bearND created this task.Jan 17 2019, 4:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 17 2019, 4:06 PM
Pchelolo closed this task as Resolved.Jan 17 2019, 8:04 PM
Pchelolo claimed this task.
Pchelolo added a subscriber: Pchelolo.

Fixed and deployed.