Page MenuHomePhabricator

mapframe dynamic maps (maplink) don't always work
Closed, ResolvedPublic

Description

Since a few days ago, mapframe dynamic maps don't reliably work.

On the page ru:Пизанская башня I get the error

Failed to load resource: the server responded with a status of 400 ()

The resource in question is https://maps.wikimedia.org/geoline?getgeojson=1&ids=Q39054 and it returns

"headers is not defined"

An other kind of error is on fr:Foire de Liège:

load.php?debug=false&lang=fr&modules=jquery|mediawiki.page.gallery&skin=vector&version=03l1ewh:51 jQuery.Deferred exception: Cannot set property 'dataGroup' of undefined TypeError: Cannot set property 'dataGroup' of undefined
    at ExternalGroup.<anonymous> (<anonymous>:29:929)
    at Function.each (https://fr.wikipedia.org/w/load.php?debug=false&lang=fr&modules=jquery%7Cmediawiki.page.gallery&skin=vector&version=03l1ewh:4:868)
    at <anonymous>:29:656
    at mightThrow (https://fr.wikipedia.org/w/load.php?debug=false&lang=fr&modules=jquery%7Cmediawiki.page.gallery&skin=vector&version=03l1ewh:48:856)
    at process (https://fr.wikipedia.org/w/load.php?debug=false&lang=fr&modules=jquery%7Cmediawiki.page.gallery&skin=vector&version=03l1ewh:49:516) undefined

These errors are temporary because now a few minutes later both work again.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 22 2019, 7:35 AM
The_RedBurn updated the task description. (Show Details)Jan 22 2019, 7:43 AM
Pikne added a subscriber: Pikne.Jan 22 2019, 8:52 AM

I've also experienced this over the past days. For instance, if I currently refresh this static snapshot, then occasionally it gives "Bad geojson - unknown type ExternalData" and occasionally it gives an image. Maybe it relates to T198622?

This looks related to the upgrade to Debian Stretch that we've started to rollout last week. There is a patch that has not yet been ported to our Stretch deployment. The fix is coming up shortly (thanks @MSantos !).

Thanks for reporting the issue, and sorry for the mess!

Mentioned in SAL (#wikimedia-operations) [2019-01-22T14:34:35Z] <gehel> monkey patch kartotherian configuration to re-add proxy on maps100[34] - T214350

Gehel added a comment.Jan 22 2019, 3:14 PM

It looks like the issue is related to https://gerrit.wikimedia.org/r/#/c/maps/kartotherian/deploy/+/463893/ (which removed proxy from kartotherian configuration).

MSantos closed this task as Resolved.Jan 22 2019, 3:15 PM
MSantos claimed this task.
Pikne added a comment.Feb 1 2019, 12:44 PM

I note that link to geoline service in task description still doesn't return coordinates as expected. The same object returns coordinates via geoshape service though. Another object Q22330964 was available via geoline service a few weeks ago and displayed via mapframe, but no longer does, though associated OSM object doesn't seem to have changed. Was that fixed too and is expected to be alright soon, or is that something else?

MSantos added a comment.EditedFeb 1 2019, 8:03 PM

@Pikne it seems that it is more related to the OSM replication system but I can't replicate this specific object that you suggested (see image below), I will start invetigating this problem and see if there is an issue with that.

Pikne added a comment.Mar 13 2019, 7:14 AM

@Pikne it seems that it is more related to the OSM replication system but I can't replicate this specific object that you suggested (see image below), I will start invetigating this problem and see if there is an issue with that.

That's weird, I still get only {"type":"FeatureCollection","features":[]} for this geoline. Does this mean that you also see this object highlighted on map in relevant Wikipedia article (in the same way this map syntax works in this article) instead of map being zoomed out to world extent due to no external data returned?

MSantos reopened this task as Open.Mar 13 2019, 12:55 PM
MSantos closed this task as Resolved.Mar 13 2019, 1:00 PM

@Pikne, in fact, I can't reproduce my previous test anymore. But the bug is better described here T218097: [Bug] Some OSM relations didn't become polygons and are not been served through geoshapes service

PS: I re-opened the task but it is not related to the actual bug.