Page MenuHomePhabricator

Sometimes, page popups appear instead of reference previews
Closed, ResolvedPublic2 Story Points

Description

Bug description
The reference popups are sometimes showing a popup for the page they are sitting on

Steps to reproduce:

or

But both cannot be reproduced reliably

Notes

Side note
As a first step, a bug was fixed, where colons in the reference names created unwanted behavior.

Event Timeline

Change 486854 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/Popups@master] Add missing escaping for jQuery ID selector

https://gerrit.wikimedia.org/r/486854

This happens when the name of a reference contains a : character. jQuery requires that almost every special character must be escaped to be able to use it as a plain text character in an ID or class name. See http://api.jquery.com/category/selectors/. We did not anticipated this. I guess we unintentionally limited our tests so far to the characters set used for identifiers in programming languages. ;-)

Patch-For-Review:

Change 486854 merged by jenkins-bot:
[mediawiki/extensions/Popups@master] Add missing escaping for jQuery ID selector

https://gerrit.wikimedia.org/r/486854

Lea_WMDE renamed this task from Reference popups somtimes showing a page popup to Sometimes, page popups appear instead of reference previews.Jan 29 2019, 2:00 PM
Lea_WMDE triaged this task as Normal priority.
Lea_WMDE updated the task description. (Show Details)
Lea_WMDE set the point value for this task to 5.

Note: This might be fixed with the latest improvements in the code base. At least I could not reproduce the issue while looking into T214693.

WMDE-Fisch changed the point value for this task from 5 to 2.

This really seems to be fixed now, just leaving some points to recheck.

Lea_WMDE closed this task as Resolved.Feb 11 2019, 8:20 AM
Lea_WMDE claimed this task.
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2019-02-06 board.