Page MenuHomePhabricator

Create uploader user group on thwiki
Closed, ResolvedPublic

Description

Hello, Please create uploader (ผู้อัปโหลด) user group and remove related-upload rights from Registered users on Thai wikipedia.

For details:

  1. Uploader have a upload, reupload, reupload-shared, reupload-own, and movefile rights.
  2. Remove a upload, and reupload rights from autoconfirmed and confirmed users group.
  3. Remove a reupload-own rights from (Registered) users group.
  4. Add a reupload-own rights to sysop group.
  5. Sysop can add/remove a uploader group.

For consensus: https://th.wikipedia.org/wiki/วิกิพีเดีย:สภากาแฟ/อภิปราย/ระงับการอัพโหลดไฟล์โดยผู้ใช้ทั่วไป

Thank you.

Event Timeline

Geonuch created this task.Feb 20 2019, 1:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 20 2019, 1:50 PM
B20180 added a subscriber: B20180.Feb 20 2019, 1:59 PM
Zoranzoki21 added a subscriber: Zoranzoki21.

Will process..
Macro catbowtie: T216615 Dis is so big request :)

Restricted Application added a project: User-Zoranzoki21. · View Herald TranscriptFeb 20 2019, 6:15 PM
Geonuch updated the task description. (Show Details)Feb 21 2019, 5:34 AM

Let me make a summary:

  1. You want to we make new right uploader.
  2. Uploader right should include upload, reupload, upload-shared, reupload-own and movefile rights
  3. Autoconfirmed and confirmed group shouldn't have upload and reupload rights
  4. Registred users shouldn't have reupload-own right
  5. Sysops can add/remove uploader right

Is everything correct?

Let me make a summary:

  1. You want to we make new right uploader.
  2. Uploader right should include upload, reupload, upload-shared, reupload-own and movefile rights
  3. Autoconfirmed and confirmed group shouldn't have upload and reupload rights
  4. Registred users shouldn't have reupload-own right
  5. Sysops can add/remove uploader right

    Is everything correct?

Yes, and sysops should have reupload-own right.

Tvcccp added a subscriber: Tvcccp.Feb 27 2019, 7:32 PM
Zoranzoki21 triaged this task as Normal priority.Mar 25 2019, 10:21 PM

Triaged just for me. Should have this deployed until the end of this week.

Zoranzoki21 removed Zoranzoki21 as the assignee of this task.Apr 2 2019, 3:01 PM
Zoranzoki21 removed a project: User-Zoranzoki21.

Sorry, because of much things to do in real life, I no have much free time to do on this task.

Sorry, because of much things to do in real life, I no have much free time to do on this task.

That's fine. I hope that somebody will claim this task again. We looking forward to uploader right for a long time.

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptApr 4 2019, 5:16 PM

Change 501363 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Create uploader user group for thwiki

https://gerrit.wikimedia.org/r/501363

Will be deployed next week.

Will be deployed next week.

Thank you so much.

Scheduled for Monday, 08 April 2019. Will be deployed between 11:00 and 12:00 UTC.

@Urbanecm I have see in gerrit. You should remove upload, and reupload from "confirmed" as well.

@Urbanecm I have see in gerrit. You should remove upload, and reupload from "confirmed" as well.

Thank you for reviewing the commit. However, removing upload, and reupload from confirmed isn't necessary, since confirmed is always autoconfigured to be the exact copy of autoconfirmed, regardless what's configured directly for confirmed. In another words, it's not technically possible to have confirmed with other permissions than autoconfirmed has. Any configuration for confirmed simply doesn't have any effect.

@Urbanecm I have see in gerrit. You should remove upload, and reupload from "confirmed" as well.

Thank you for reviewing the commit. However, removing upload, and reupload from confirmed isn't necessary, since confirmed is always autoconfigured to be the exact copy of autoconfirmed, regardless what's configured directly for confirmed. In another words, it's not technically possible to have confirmed with other permissions than autoconfirmed has. Any configuration for confirmed simply doesn't have any effect.

Thank you for explaining, I understand.

Horus added a comment.Apr 8 2019, 5:23 AM

@Geonuch From my understanding, confirmed group also requires admin individual validation (and thus, differentiated it from autoconfirmed group). Currently Thai Wikipedia has no user with confirmed group.

Change 501363 merged by jenkins-bot:
[operations/mediawiki-config@master] Create uploader user group for thwiki

https://gerrit.wikimedia.org/r/501363

Mentioned in SAL (#wikimedia-operations) [2019-04-08T11:25:49Z] <hoo@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Create uploader user group for thwiki (T216615) (duration: 00m 58s)

It success. I can't upload. Thanks everyone.

Urbanecm closed this task as Resolved.Apr 8 2019, 11:43 AM

Deployed. Should you notice any issues, please reopen&comment.