Page MenuHomePhabricator

New protection levels on german wiktionary
Closed, ResolvedPublic

Description

Currently we have two protection levels for pages in the german wiktionary.

  • Protect-level-autoconfirmed
  • Protect-level-sysop

We want two new levels to have not only admins to edit some pages. See discussion: https://de.wiktionary.org/wiki/Wiktionary:Teestube#Umfrage_und_Abstimmung_zu_weiteren_Seitenschutzstufen

New levels should be:

  • Protect-level-autoreview - assigned to groups (autoreview, editor, bot, sysop)
  • Protect-level-editor - assigned to groups (editor, bot, sysop)

I hope this is possible.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterCreate new protection levels for dewiktionary
operations/mediawiki-config : masterAdded new protection levels for dewiktionary

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 23 2019, 2:36 PM
Udo_T added a subscriber: Udo_T.Feb 23 2019, 2:40 PM
Restricted Application added a project: User-Zoranzoki21. · View Herald TranscriptFeb 23 2019, 7:39 PM

Change 492534 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[operations/mediawiki-config@master] Added new protection levels for dewiktionary

https://gerrit.wikimedia.org/r/492534

Udo_T added a comment.EditedMar 3 2019, 10:41 AM

Hi,

When can we expect the implementation of the protection levels? Do you need additional information from us?

Best regards
Udo T.

Hi,
When can we expect the implementation of the protection levels? Do you need additional information from us?
Best regards
Udo T.

Hi, basically a patch was uploaded for this task by @Zoranzoki21 but need some adaptation. Then he will add it to a deployment window to push it to the servers. It can take some time, sorry.

Change 492534 abandoned by Zoranzoki21:
Added new protection levels for dewiktionary

Reason:
I no have much free time.

https://gerrit.wikimedia.org/r/492534

Zoranzoki21 removed Zoranzoki21 as the assignee of this task.Mar 6 2019, 4:42 PM
Zoranzoki21 added subscribers: Urbanecm, Zoranzoki21.

I am sorry, but I am not sure how I can fix it. @Urbanecm or anyone else can you claim this instead of me?

Ammarpad claimed this task.EditedMar 10 2019, 9:12 AM
Ammarpad added a subscriber: Ammarpad.

I am sorry, but I am not sure how I can fix it. @Urbanecm or anyone else can you claim this instead of me?

Let me take over. Thank you for the start.

Ammarpad triaged this task as Medium priority.Mar 10 2019, 9:13 AM

Change 495918 had a related patch set uploaded (by Ammarpad; owner: Ammarpad):
[operations/mediawiki-config@master] Create new protection levels for dewiktionary

https://gerrit.wikimedia.org/r/495918

Udo_T added a comment.Apr 25 2019, 6:10 PM

As I understand it, the change only needs one or two more code reviews.

Are there any problems preventing further reviews?

Best regards
Udo T.

Udo_T added a comment.May 19 2019, 4:57 PM

Hi @Urbanecm, I would like to ask you, what's the reason for the long duration? Until when can we expect an implementation of the change?

Best regards
Udo T.

Hello @Urbanecm, @Ammarpad needs to schedule it for deployment. @Ammarpad, you can do it by going to https://wikitech.wikimedia.org/wiki/Deployments, then choosing any SWAT window (EU, Morning, Evening), schedule the patch (something like * [config] {{gerrit|gerritnumber}} description) and be at IRC (freenode), #wikimedia-operations channel during the window you chosen. Thanks!

Urbanecm added a project: User-Urbanecm.

Scheduled for today EU SWAT.

Change 495918 had a related patch set uploaded (by Urbanecm; owner: Ammarpad):
[operations/mediawiki-config@master] Create new protection levels for dewiktionary

https://gerrit.wikimedia.org/r/495918

Change 495918 merged by jenkins-bot:
[operations/mediawiki-config@master] Create new protection levels for dewiktionary

https://gerrit.wikimedia.org/r/495918

Mentioned in SAL (#wikimedia-operations) [2019-06-04T11:23:07Z] <urbanecm@deploy1001> Synchronized wmf-config/InitialiseSettings.php: [[:gerrit:495918|Create new protection levels for dewiktionary]] (1/2, T216885) (duration: 00m 47s)

Mentioned in SAL (#wikimedia-operations) [2019-06-04T11:24:09Z] <urbanecm@deploy1001> Synchronized wmf-config/CommonSettings.php: [[:gerrit:495918|Create new protection levels for dewiktionary]] (2/2, T216885) (duration: 00m 47s)

Urbanecm closed this task as Resolved.Jun 4 2019, 11:42 AM

Deployed.

Udo_T added a comment.Jun 4 2019, 11:53 AM

Hi @Urbanecm, many thanks. I have already tested it and everything works great as desired.

Best regards
Udo

Happy to help!