Page MenuHomePhabricator

Record of participants improvements
Closed, ResolvedPublicBug

Description

Steps to Reproduce

*I tried to add 3 times some depicts for a single image (I added the depict, then clicked save. 3 times)
*Then I go to Campaign home page

Actual Results:
I have 3 contributions recorded

Expected Results:
I should have only 1 (1 image improved, 1 contribution, no matter how many times I clicked save)

Event Timeline

Anthere created this task.Fri, May 17, 12:16 PM
Anthere updated the task description. (Show Details)Fri, May 17, 1:40 PM

Also ... when you click "save" on depicts .. then you are thrown back to the image at the start of the process, not the image that you have just been working on.

Also ... if you open the campaign for a second / third / etc. time you arrive on the same page as the first starting image. Not where you left off, or a random image ... if you do a lot of additions to a lot of images, this would be irritating to have to scroll through those you have already worked on to get to "new" images to add to.

Eugene233 moved this task from Backlog to Incoming Bugs on the ISA board.Tue, May 21, 8:27 PM

Also ... when you click "save" on depicts .. then you are thrown back to the image at the start of the process, not the image that you have just been working on.

@Islahaddow This should be another bug I suggest?

Also ... if you open the campaign for a second / third / etc. time you arrive on the same page as the first starting image. Not where you left off, or a random image ... if you do a lot of additions to a lot of images, this would be irritating to have to scroll through those you have already worked on to get to "new" images to add to.

So do we present them a random image? (This should be another task as well)

Change 511847 had a related patch set uploaded (by Eugene233; owner: Eugene233):
[labs/tools/Isa@master] Record of participants improvements

https://gerrit.wikimedia.org/r/511847

Eugene233 moved this task from Incoming Bugs to In progress on the ISA board.

This has been discussed in the past (see notes in meeting notes) and been described in page Tool WLA Requirements

I am copying the notes in the Tool WLA Requirements here

All images are served (whether they have depicts/captions fields or not. But images are only served once to a User. Comment : Display of image: attribute weight to the amount of info available on an image so that more chance to display an image with no depicts than one with lot’s of depict

I enter a new bug for this

Also ... when you click "save" on depicts .. then you are thrown back to the image at the start of the process, not the image that you have just been working on.

Isla, please make sure to enter a new bug entry for new bugs. Do not add them in comment. It will make Eugene job much more complicated to track them and deal with them. Only unique report is the way to go ;)

Change 511847 merged by jenkins-bot:
[labs/tools/Isa@master] Record of participants improvements

https://gerrit.wikimedia.org/r/511847

Eugene233 closed this task as Resolved.Thu, May 23, 12:58 PM