Page MenuHomePhabricator

[Regression pre-wmf.7] "Uncaught TypeError: this.getSurface(...).setSurfacePadding is not a function" error appears when scrolling the page in VE or Source editor
Closed, ResolvedPublic

Description

Steps to replicate:

  1. Open VE/Source editor
  2. Scroll the page

There is an error appearing in the console at this point: Uncaught TypeError: this.getSurface(...).setSurfacePadding is not a function

I noticed something else after this error surfaces which looks pretty serious, not sure whether it's relevant to this error. But mentioning it here just in case:

  1. After step 2, make some changes after this error appears,
  2. Go to Save Changes dialog,
  3. Go to Diff panel by clicking on "Review your changes"
  4. Click on "Save changes"
  5. Now click on "Edit source"/"Edit", none of the editor opens.

Also, you wont be able to switch to any other tab from this point, not even Read mode.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 23 2019, 11:14 PM
Ryasmeen updated the task description. (Show Details)May 23 2019, 11:24 PM
Ryasmeen updated the task description. (Show Details)May 23 2019, 11:29 PM
Ryasmeen triaged this task as Unbreak Now! priority.May 23 2019, 11:31 PM
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMay 23 2019, 11:31 PM

I think this should be UBN since it blocks opening the editor, feel free to change the priority if you think otherwise.

Change 512304 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[VisualEditor/VisualEditor@master] ve.init.Target: Fix errant call to setSurfacePadding, not setPadding

https://gerrit.wikimedia.org/r/512304

Esanders moved this task from Incoming to QA on the VisualEditor (Current work) board.

Change 512304 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.init.Target: Fix errant call to setSurfacePadding, not setPadding

https://gerrit.wikimedia.org/r/512304

Change 512305 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (68b031087)

https://gerrit.wikimedia.org/r/512305

Change 512305 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (68b031087)

https://gerrit.wikimedia.org/r/512305

Ryasmeen edited projects, added Verified; removed Patch-For-Review.May 25 2019, 6:45 AM
Ryasmeen moved this task from QA to Product owner review on the VisualEditor (Current work) board.
ppelberg closed this task as Resolved.Jun 24 2019, 9:10 PM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 24 2019, 9:10 PM