Page MenuHomePhabricator

Using five apostrophes in Arabic Wikipedia editor, it is not parsed as bold+italic, but only italic surrounded by two apostrophes (due to local CSS)
Closed, InvalidPublic

Description

Hello,

Before few days some users in arwiki notice this problem

Problem (Example)
''word'' = word
'''word''' = word
'''''word''''' = "word"

Expected (Example)
''word'' = word
'''word''' = word
'''''word''''' = word

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 24 2019, 9:28 PM
Schnark closed this task as Invalid.May 25 2019, 9:03 AM
Schnark added a subscriber: Schnark.

https://ar.wikipedia.org/wiki/%D9%85%D9%8A%D8%AF%D9%8A%D8%A7%D9%88%D9%8A%D9%83%D9%8A:Common.css includes the following rules:

/*[[قالب:قول]] وغيره*/
i>b,b>i{font-weight:normal;font-style:normal;display:inline-block}
i>b::before,b>i::before,.quot::before{content:open-quote;}
i>b::after,b>i::after,.quot::after{content:close-quote;}

So, yes, nested bold and italic is neither bold nor italic and has double quotes at the start and the end, but this is local CSS problem, not a bug in MediaWiki.

Aklapper renamed this task from Typewriter apostrophe not working well in Arabic Wikipedia to Using five apostrophes in Arabic Wikipedia editor, it is not parsed as bold+italic, but only italic surrounded by two apostrophes.May 25 2019, 9:07 AM
Aklapper reopened this task as Open.
Aklapper edited projects, added MediaWiki-Parser; removed Wikimedia-Site-requests.
Aklapper closed this task as Invalid.May 25 2019, 9:23 AM
Aklapper removed a project: MediaWiki-Parser.

Garrr. Big thanks to @Schnark for investigating, and I am sorry for my editing collision here.

Aklapper renamed this task from Using five apostrophes in Arabic Wikipedia editor, it is not parsed as bold+italic, but only italic surrounded by two apostrophes to Using five apostrophes in Arabic Wikipedia editor, it is not parsed as bold+italic, but only italic surrounded by two apostrophes (due to local CSS).May 25 2019, 9:23 AM

@alanajjar: On an unrelated note, ar.wikipedia.org shos many errors in the Developer Tools of anybody's web browser. The Arabic Wikipedia community must fix these errors in their local gadgets' code: