Page MenuHomePhabricator

English interwiki link not shown for some articles on id.wp even though links exist (due to local SidebarTranslation.js gadget)
Closed, InvalidPublic

Description

It only happens when I'm logged in, it doesn't seem to behave like this when I'm logged out, or logged in as my bot.

Steps to reproduce:

  1. Logged in as me :)
  2. Go to a page in id.wiki (for example in the screenshot I used Saint Vincent dan Grenadine)
  3. The interwiki for English WP doesn't appear on the shortlist, so I searched for "Inggris" or "English", both showing the autocomplete, but it doesn't appear in the search result. I looked
  • On the list of "Whole world" (Seluruh dunia), English also doesn't appear
  • On the list of "America" (Amerika), English also doesn't appear
  • Only in the list of "Europe" does English appear

Based on the suggestion and sorted result, it seems that the German language (Jerman) had an unusually high position, and it appears in all continent. Not sure if this is related or not.

It happened for quite a while now, not sure when I first noticed it. And it happens in many pages, but not all. For example US, Bahamas have the same problem, but some random page doesn't





Event Timeline

Bennylin created this task.Jun 8 2019, 5:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 8 2019, 5:26 PM
Aklapper renamed this task from Could not find the English interwiki, even though it exists to English interwiki link not shown for some articles on id.wp for a specific user, even though links exist.Jun 8 2019, 8:43 PM
Aklapper added a project: ULS-CompactLinks.
Restricted Application added a project: UniversalLanguageSelector. · View Herald TranscriptJun 8 2019, 8:43 PM

Cannot reproduce here...

Is "English" shown in the list of all languages after you have disabled the compact language links feature?

Amire80 added a subscriber: Amire80.Jun 8 2019, 8:57 PM

I cannot reproduce it as an anonymous user or as Amire80.

However, I can reproduce it if I enable the gadget "Terjemahkan interwiki ke dalam bahasa Indonesia".

I'll try to debug it out of curiosity, but it will be best if whoever developed the gadget takes a look at it.

Aklapper renamed this task from English interwiki link not shown for some articles on id.wp for a specific user, even though links exist to English interwiki link not shown for some articles on id.wp even though links exist (due to local SidebarTranslation.js gadget).Jun 8 2019, 9:40 PM
Aklapper closed this task as Invalid.

Thanks Amir!
Indeed, I can confirm the problem after enabling the gadget "Terjemahkan interwiki ke dalam bahasa Indonesia". Looking at https://id.wikipedia.org/wiki/MediaWiki:Gadgets-definition that gadget seems to be SidebarTranslation[ResourceLoader]|SidebarTranslation.js located at https://id.wikipedia.org/wiki/MediaWiki:Gadget-SidebarTranslation.js and loading https://id.wikipedia.org/wiki/MediaWiki:Langcode2name.js

@Bennylin: I am closing this task as invalid as the problem to solve is in local on-wiki content (local code in that gadget), which is out of scope for Phabricator. For future reference, https://www.mediawiki.org/wiki/Help:Locating_broken_scripts explains how you can test yourself if a problem happens because of a gadget.

Thanks Amir and Andre!

Perhaps you can simply import the version from the English Wikipedia: https://en.wikipedia.org/wiki/MediaWiki:Gadget-SidebarTranslate.js

Perhaps you can simply import the version from the English Wikipedia: https://en.wikipedia.org/wiki/MediaWiki:Gadget-SidebarTranslate.js

Also see https://www.mediawiki.org/wiki/ResourceLoader/Migration_guide_(users)#Keep_gadgets_central why to not copy and paste code and then not maintain the copied code and let the copied code rot...

Perhaps you can simply import the version from the English Wikipedia: https://en.wikipedia.org/wiki/MediaWiki:Gadget-SidebarTranslate.js

Also see https://www.mediawiki.org/wiki/ResourceLoader/Migration_guide_(users)#Keep_gadgets_central why to not copy and paste code and then not maintain the copied code and let the copied code rot...

Yes! Thanks for this link.