Page MenuHomePhabricator

EventBusMonologHandler: Malformed UTF-8 characters, possibly incorrectly encoded. Aborting send.
Closed, ResolvedPublic

Description

#0 /srv/mediawiki/php-1.34.0-wmf.13/extensions/EventBus/includes/EventBus.php(133): EventBus::serializeEvents(array)
#1 /srv/mediawiki/php-1.34.0-wmf.13/extensions/EventBus/includes/adapters/monolog/EventBusMonologHandler.php(61): EventBus->send(array)
#2 /srv/mediawiki/php-1.34.0-wmf.13/includes/deferred/MWCallableUpdate.php(38): Closure$EventBusMonologHandler::write()
#3 /srv/mediawiki/php-1.34.0-wmf.13/includes/deferred/DeferredUpdates.php(309): MWCallableUpdate->doUpdate()
#4 /srv/mediawiki/php-1.34.0-wmf.13/includes/deferred/DeferredUpdates.php(265): DeferredUpdates::attemptUpdate(MWCallableUpdate, Wikimedia\Rdbms\LBFactoryMulti)
#5 /srv/mediawiki/php-1.34.0-wmf.13/includes/deferred/DeferredUpdates.php(225): DeferredUpdates::handleUpdate(MWCallableUpdate, Wikimedia\Rdbms\LBFactoryMulti, string, integer)
#6 /srv/mediawiki/php-1.34.0-wmf.13/includes/deferred/DeferredUpdates.php(144): DeferredUpdates::handleUpdateQueue(array, string, integer)
#7 /srv/mediawiki/php-1.34.0-wmf.13/includes/MediaWiki.php(926): DeferredUpdates::doUpdates(string)
#8 /srv/mediawiki/php-1.34.0-wmf.13/includes/MediaWiki.php(750): MediaWiki->restInPeace(string, boolean)
#9 [internal function]: Closure$MediaWiki::doPostOutputShutdown()

The impacted URL is search related, the root cause is likely in CirrusSearch.

Event Timeline

dcausse created this task.Jul 19 2019, 8:35 AM
Restricted Application edited projects, added Discovery-Search; removed Discovery-Search (Current work). · View Herald TranscriptJul 19 2019, 8:35 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 524474 had a related patch set uploaded (by DCausse; owner: DCausse):
[mediawiki/extensions/CirrusSearch@master] Use sanitized request params

https://gerrit.wikimedia.org/r/524474

dcausse triaged this task as Normal priority.Jul 19 2019, 8:52 AM
dcausse moved this task from in progress to Needs review on the Discovery-Search (Current work) board.

Change 524474 merged by jenkins-bot:
[mediawiki/extensions/CirrusSearch@master] Use sanitized request params and headers

https://gerrit.wikimedia.org/r/524474

Change 526731 had a related patch set uploaded (by DCausse; owner: DCausse):
[mediawiki/extensions/CirrusSearch@master] Normalize request param name

https://gerrit.wikimedia.org/r/526731

Change 526731 merged by jenkins-bot:
[mediawiki/extensions/CirrusSearch@master] Normalize request param name

https://gerrit.wikimedia.org/r/526731

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:06 PM
debt closed this task as Resolved.Sep 5 2019, 6:34 PM