Page MenuHomePhabricator

Selection of text misses starting character(s) for complex scripts like Telugu
Open, Stalled, Needs TriagePublic

Description

Steps to Reproduce:

  • Enable 2010 Wikieditor toolbar in preferences.
  • Open any page to edit
  • paste మండల
  • copy some other text on the screen and paste somewhere else to make sure that the paste buffer has been changed.
  • Try to select the pasted word using keyboard from the right most character and stop when you see the entire word selected.
  • Paste it in search toolbar

Actual Results:

ండల
Expected Results:
మండల

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 22 2019, 4:14 AM
Aklapper changed the task status from Open to Stalled.Jul 22 2019, 10:29 AM

Cannot reproduce in Firefox or Chrome on Linux. I pasted the word in the first line of the editor window. Then I marked and copied the word. Then I pasted the word in the Search field in the upper right corner. See screenshot:

Please always include browser information, browser version information, operating system information when reporting issues.
Also, does the problem happen when using safemode?

Aklapper closed this task as Declined.Aug 9 2019, 5:52 AM

Unfortunately closing this report as no further information has been provided.

@Arjunaraoc: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Arjunaraoc reopened this task as Open.EditedAug 13 2019, 8:43 AM

Sorry for the delay in responding.

I checked and found the issue. You will be able to see it when you select the text using keyboard, starting from the right. when the first character is shown as selected, then copy and try. Also make sure to copy some thing else before, if you have just pasted the same text, before you try selecting text with keyboard.

Ubuntu 18.04
Firefox 68.0.1. 64 bit

Chrome: Version 73.0.3683.103 (Official Build) (64-bit)

I have tried in windows 10 as well with Firefox. The behavior is same. In the typical editor like gedit on Ubuntu, selection using keyboard works fine,

I have updated the main task instructions as per this comment.

Arjunaraoc updated the task description. (Show Details)Aug 13 2019, 8:45 AM

Hi @Arjunaraoc, please see my previous comments and answer all questions:

Also, does the problem happen when using safemode?

Aklapper changed the task status from Open to Stalled.Aug 18 2019, 2:39 PM

Hi @Aklapper , Yes I verified that the problem is present in safemode as well.

In practice, during editing, I have found that even selecting with mouse also results in the same problem.

Aklapper added a comment.EditedAug 20 2019, 8:23 PM

Cannot reproduce. The screenshot first shows copying in editor (from left to right), and then the pasted word in the search field. Firefox 68 on Fedora Linux.

Arjunaraoc added a comment.EditedAug 22 2019, 3:51 AM

@Aklapper, Thanks for your update. I have requested other Telugu wikipedia editors to verify and report.

Arjunaraoc added a comment.EditedWed, Sep 4, 12:35 AM

After further experimentation, I found that I am using Native keyboard support installed for English and Telugu. With this setting, I am able to use ULS in searchbox but not in the main text entry area of page. Whether I select Transliteration or Inscript and save the settings, ULS fails to work. All my text input, even after changing language (CTRL+M) continues to be in English. Even on Windows 10, I use native keyboard support for English and Telugu, so I was able to reproduce it in Windows 10 environment as well.

I also find this problem is present while editing on https://en.wikipedia.org but not on
https://www.mediawiki.org/

@Aklapper, Can you try to reproduce? @Amire80, can you help?

I cannot try to reproduce as I do not have a system running Microsoft Windows, sorry.

Aklapper changed the task status from Stalled to Open.Thu, Sep 5, 9:54 AM
TheDJ added a subscriber: TheDJ.Thu, Sep 5, 12:17 PM

Maybe the Language-Team can assist ?

@Aklapper, Can you try to reproduce? @Amire80, can you help?

I found the problem in Ubuntu 18.04 with English and Telugu language support installed. You can try if possible in your linux machine.

You can try if possible in your linux machine.

I guess I'd need clearer steps which input method this refers to, plus information which keys I'd have to press on my physical keyboard to reproduce. My physical keyboard is a QWERTY keyboard with a US layout.

@Aklapper , Thanks for your update. Now that you have Telugu installed, you can simply try paste మండల and then select the word starting from rightmost. Then copy it and paste it elsewhere

As requested, I also give below the instructons for typing the word in Telugu.

Select second option for Telugu in your screenshot. This is the basic Inscript layout. Type cx[n to get మండల.

After choosing the second input method from the screenshot in T228611#5470648 (see upper right corner of screenshot below) and following your steps (paste word; copy and paste some other word into the line below; use keyboard arrows and shift to mark the entire word starting from the right), I still cannot reproduce the problem. Firefox 69 on Fedora 30.

Aklapper changed the task status from Open to Stalled.Mon, Sep 16, 1:01 PM

@Aklapper

Thanks for your update..

After further experimentation, I found that I am using Native keyboard support installed for English and Telugu. With this setting, I am able to use ULS in searchbox but not in the main text entry area of page. Whether I select Transliteration or Inscript and save the settings, ULS fails to work. All my text input, even after changing language (CTRL+M) continues to be in English. Even on Windows 10, I use native keyboard support for English and Telugu, so I was able to reproduce it in Windows 10 environment as well.
I also find this problem is present while editing on https://en.wikipedia.org but not on
https://www.mediawiki.org/

As given in my earlier comment(reproduced above), the problem does not exist on mediawiki.org. Please try on a language Wikipedia, preferably te.wikipedia.org or en.wikipedia.org

@Arjunaraoc: Cannot reproduce.

Has anyone else seen the same problem? If yes, on which browser and operating system?

  1. Went to https://te.wikipedia.org/w/index.php?title=వాడుకరి:AKlapper_(WMF)/Sandbox&action=edit
  2. Switched desktop input method to Telegu
  3. Pasted "మండల" from T228611
  4. Pressed Enter on keyboard to add two line breaks
  5. Pasted words "some other text" from T228611
  6. Used keyboard to go up with arrow keys and then mark/highlight "మండల" starting from the right
  7. Copied via Ctrl+C
  8. Pasted in search field via Ctrl+V

Arjunaraoc added a comment.EditedWed, Sep 18, 7:06 AM

@Aklapper , Thanks for your effort to reproduce. Most people on Telugu Wikipedia are using ULS, so they are not facing the problem. I am using Ubuntu 18.04 Budgie, with native keyboard support for Telugu and not m17n software. Now we need someone to reproduce it on Windows to proceed further,

@Arjunaraoc: Has anyone else seen and reproduced this problem? If yes, on which browser and operating system?

@Aklapper, Sorry my previous comment led to a wrong conclusion by you. I meant that as the Linux userbase is quite small, I lost the hope that it could be reproduced, I am hoping that may be some one from windows user base if they happen to use Windows Telugu keyboard may be able to reproduce the issue,