Page MenuHomePhabricator

PollNY DB Query Errors
Closed, ResolvedPublic

Description

Per @TheVoidwalker on https://phabricator.miraheze.org/T4579 the error:

2019-07-29 13:09:03 test1 test1wiki: [179c0835c6dd08d234c20f51] /wiki/Special:CreatePoll Wikimedia\Rdbms\DBQueryError from line 1587 of /srv/mediawiki/w/includes/libs/rdbms/database/Database.php: A database query error has occurred. Did you forget to run your application's database schema updater after upgrading?
Query: INSERT INTO poll_choice (pc_poll_id,pc_text,pc_order) VALUES ('2','test1','1')
Function: Poll::addPollChoice
Error: 1364 Field 'pc_vote_count' doesn't have a default value (mediawiki-internal-db-master.miraheze.org)

is experienced when trying to create a poll

Event Timeline

Restricted Application added a project: Social-Tools. · View Herald TranscriptJul 30 2019, 7:35 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Znotch190711 triaged this task as Normal priority.Jul 30 2019, 7:42 AM
RhinosF1 renamed this task from Review for Reception123, Brent Laabs and other Miraheze sysadmins: bug for PollNY to PollNY DB Query Errors.Jul 30 2019, 7:42 AM
RhinosF1 removed Reception123 as the assignee of this task.
RhinosF1 raised the priority of this task from Normal to Needs Triage.
RhinosF1 updated the task description. (Show Details)
RhinosF1 updated the task description. (Show Details)
RhinosF1 updated the task description. (Show Details)
RhinosF1 updated the task description. (Show Details)
RhinosF1 added a subscriber: TheVoidwalker.
RhinosF1 added a subscriber: RhinosF1.

Per https://phabricator.miraheze.org/T4579 this is on Poll Extension as well.

Confirmed on test1.miraheze.org running 1.33MW — PollNY 3.5.0

ashley added a subscriber: ashley.Jul 30 2019, 10:03 AM

Per https://phabricator.miraheze.org/T4579 this is on Poll Extension as well.

You should probably open a separate ticket about that. (AIUI the Poll extension is pretty much unmaintained and for generic (non-social) pollls you may want to consider using AJAXPoll instead, but I'm biased since I'm one of the maintainers of AJAXPoll.)

As for this (PollNY) issue, I can't reproduce this, not on my devbox nor on any production platform I have access to. It might be something like T220879 and other "exotic" issues which are a problem on WMF CI and other non-standard setups which have a stricter MySQL configuration. More information about the MySQL configuration of the box where PollNY SQL is failing would likely help in narrowing down the cause of this issue.

RhinosF1 added a comment.EditedJul 30 2019, 11:08 AM

Per https://phabricator.miraheze.org/T4579 this is on Poll Extension as well.

You should probably open a separate ticket about that. (AIUI the Poll extension is pretty much unmaintained and for generic (non-social) pollls you may want to consider using AJAXPoll instead, but I'm biased since I'm one of the maintainers of AJAXPoll.)

I think AJAX Poll is an option on the wiki farm

As for this (PollNY) issue, I can't reproduce this, not on my devbox nor on any production platform I have access to. It might be something like T220879 and other "exotic" issues which are a problem on WMF CI and other non-standard setups which have a stricter MySQL configuration. More information about the MySQL configuration of the box where PollNY SQL is failing would likely help in narrowing down the cause of this issue.

Not sure, let’s wait for a Miraheze sysadmin.

Change 526419 had a related patch set uploaded (by Paladox; owner: Paladox):
[mediawiki/extensions/PollNY@master] Set pc_vote_count in addPollVote

https://gerrit.wikimedia.org/r/526419

Change 526419 merged by jenkins-bot:
[mediawiki/extensions/PollNY@master] Make pc_vote_count an int in sql

https://gerrit.wikimedia.org/r/526419

Is this task resolved by Paladox' merged patch?

Znotch190711 added a comment.EditedAug 9 2019, 8:00 AM

@Aklapper We dont know. @RhinosF1 please go to Miraheze Phab and check out that ticket on discussing to remove extension poll ny.

Znotch190711 changed the task status from Open to Stalled.Aug 9 2019, 8:02 AM
RhinosF1 changed the task status from Stalled to Open.Aug 9 2019, 8:24 AM

PollNY was kept it was Extension:Poll we dropped and I'll grab paladox later to confirm

Paladox closed this task as Resolved.Aug 9 2019, 12:25 PM
Paladox claimed this task.