Page MenuHomePhabricator

Undeploy LanguageConverter from unilingual uniscript projects
Closed, ResolvedPublic

Description

It has been discovered that LanguageConverter has been activated apparently on an unknown number of wikis during the last months, at least German Wikipedia, some more by random trial, probably every wiki, without any notification. It is breaking existing pages, e.g. with chemical formulas or URL.

Until now, LanguageConverter has been enabled for central multilingual projects (with translate capability) and some explicit languages which use several scripting systems. See MediaWiki-Language-converter for examples and rMW /languages/LanguageConverter.php lines 41–52 (English since there seems to be a caribic variant).

Some weeks ago we learnt that related articles were activated for all wikis and skins by accident, which has been reverted meanwhile.

If the current deployment has been made deliberately:

  • By which TechNews the affected communities have been informed in advance?
  • On which mw:Help: page the new Wikisyntax has been explained?
  • Why is that not appearing in Special:Version?

See T230300 for the current incident. More broken pages seem to exist.

Feature Special:MyLanguage/ seems to be activated now on untranslated projects. Temporary bug or intentionally persistent feature?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 12 2019, 10:08 AM
cscott added a subscriber: cscott.Aug 14 2019, 2:31 PM

Duplicate of T189095 for the first part. Not a new change.

No idea about Special:MyLanguage.

I suspect Special:MyLanguage was enabled for all projects by T68762: Move "Special:MyLanguage" from Extension:Translate to MediaWiki core in June 2014.

cscott closed this task as Resolved.Aug 14 2019, 4:55 PM
cscott claimed this task.

Duplicate for the -{ change and intended feature for the Special:MyLanguage change.